Bulk meetings import from 8.1.2 to 7.12.7 not working

Hi There

After having too many issues with 8.1.2 and 8.2, I decided to downgrade to 7.12.7. So far 7.12.7 is working great. however, I have noticed a minor quirk in my attempt to import meetings that are in 8.1.2 across to 7.12.7. It gets all the way through to;

Step 2: Confirm Import File Properties

But when I click on the Next button, the panel is blank and upon checking dev console, there is a the following 500 error on index.php.

I managed to use the same function when importing Accounts and Contacts so I think its something to do with the data im importing but I cant figure it out. I am using the template provided by 7.12.7 for Meetings but this doesnt help.

Any ideas?


1 Like

incidentally, I have tried disabling cron to make sure that it isnt something to do with the Scheduler. no change. I have checked the suitecrm.log file and nothing in there either.

A 500 error usually leaves signs in the PHP error log (not suitecrm.log)

Also, often import errors are related to specific records that have something that is tripping the importer. If you can find out which record it is, it might help work around it.

You can just intuitively look for stuff that looks potentially troublesome, or be more scientific and use bisection to discover. Break your file in two, try each half, hopefully one fails and one succeeds. Use the one that fails and break it in half again. Go on until you reach a single record that you know will fail, and try to get some clues from what is different about it…

Thanks, I already tried importing a segment of the file. In fact, I downloaded the same file, which used actual data from my DB, I altered the records slightly so they were different and tested with that and still got the same error. Ill have a look at the Apache log to see if its showing anything. I set the log level in SuiteCRM to debug, it seemed to show a lot more detail, just nothing to do with the import.

ok, checked the log and this is what is going on;

[Wed Nov 02 00:50:10.517087 2022] [php:error] [pid 73721] [client 101.xx.xx.xx:64636] PHP Fatal error:  Uncaught TypeError: Cannot access offset of type string on string in /var/www/suitecrm/modules/Import/Forms.php:96\nStack trace:\n#0 /var/www/suitecrm/modules/Import/views/view.step3.php(302): getControl()\n#1 /var/www/suitecrm/include/MVC/View/SugarView.php(210): ImportViewStep3->display()\n#2 /var/www/suitecrm/include/MVC/Controller/SugarController.php(432): SugarView->process()\n#3 /var/www/suitecrm/include/MVC/Controller/SugarController.php(363): SugarController->processView()\n#4 /var/www/suitecrm/include/MVC/SugarApplication.php(101): SugarController->execute()\n#5 /var/www/suitecrm/index.php(52): SugarApplication->execute()\n#6 {main}\n  thrown in /var/www/suitecrm/modules/Import/Forms.php on line 96, referer: https://xx.com/index.php

Changed the following to fix this issue.

Line 96 in modules/Import/Forms.php to

        if (isset($vardef['function']) && ($vardef['function'] == 'getEmailAddressWidget'
                || (isset($vardef['function']['name'])
                    && $vardef['function']['name'] == 'getEmailAddressWidget')))

Line 121 in modules/Import/Forms.php to

        if (isset($vardef['function']) && ($vardef['function'] == 'getCurrencyDropDown'
                || (isset($vardef['function']['name'])
                    && $vardef['function']['name'] == 'getCurrencyDropDown')))

Maybe you could add this fix as a PR on Github? Thanks

Hi Ross, I am wanting to downgrade for the same reason. I have painstakingly imported records to v8 from Filemaker and obviously don’t want to risk losing any data. Can I ask how you downgraded? Were you able to simply install 7.12.7 and connect to the same database? Or did you need to go through an importing of records etc.

Thanks Terry

Hi Terry, I didnt downgrade my existing installation, I created a new instance on Linode and installed 7.12.7. I am slowly migrating all of the data from 8.1 to the new instance and so far havent run into any issues. The only downside is that I have opted to customise this instance manually rather than importing from 8.1 as I want a clean install to work with. So it a little more time consuming but so far im pretty happy with 7.12.7. Its running very well and besides a few minor issues, its working solidly.

Filemaker huh! Thats a blast from the past. I havent worked with that since the 90s. Is it still around or is this a legacy system? Feel free to message me to PM me in here and ill respond to any questions you have.


edit: I should say I havent run into any issues I havent been able to resolve myself or via this forum.

@TerryL sorry, you can’t downgrade; you can’t just change to the v7 code and connect to the v8 database.

You’ll have to make a clean v7 install and move the data. You might avoid some imports/exports if you move data at the database level (SQL). But you’d have to “cherry-pick” parts that are consistent, watch out for any field changes, etc.

1 Like