Blank screen system setting italian language pack

Hi, when i active the italian language, the system setting are blank.
Error on italian language pack at line 339.

Which language pack are you using and what is the error you are receiving?

Thanks,

Will.

I don’t have issues when using this language pack for italian
https://sourceforge.net/projects/suitecrmtranslations/files/

Note: after install you need to make a "quick repair " for languages and also javascript language caches (see admin screen / module quick repair)

I had the same problem. I’ve already done quick repair after installing the module. Still got:

PHP Parse error: syntax error, unexpected T_STRING, expecting ‘)’ in /var/www/html/SuiteCRM-7.3.1-MAX/modules/Configurator/language/it_IT.lang.php on line 339, referer: http://xxx/suitecrm/index.php?module=Administration&action=index

It seems that the string in that file at line 339 (and following) is wrong: there are double backslashes, so the single quote character isn’t escaped.
Removing in every occurence one of the two backslashes (or commenting the whole LBL_FONT_LIST_CIDINFO_INFO translation (about 23 lines)) solves the issue.

HTH

Hi: did you used the dowload file for suite 7.3 from here: https://sourceforge.net/projects/suitecrmtranslations/files/

Note: there is other language packs for italian by annother user so I need to be sure if there is a need to revise my packs.

Also please join in and translate online at https://www.transifex.com/projects/p/suitecrm/

There is an error in the language file. I reported it in this post. The fix is to replace the following code from line 339 to line 357.

"<pre>\$enc=\'UniCNS-UTF16-H\';<br>".
"\$cidinfo=array(\'Registry\'=>\'Adobe\', \'Ordering\'=>\'CNS1\',\'Supplement\'=>0);<br>".
"\$cidinfo=array(\'Registry\'=>\'Adobe\', \'Ordering\'=>\'CNS1\',\'Supplement\'=>0);<br>".
"include(\'include/tcpdf/fonts/uni2cid_ac15.php\');</pre>".
"</li><li>".
"Chinese Simplified :<br>".
"<pre>\$enc=\'UniGB-UTF16-H\';<br>".
"\$cidinfo=array(\'Registry\'=>\'Adobe\', \'Ordering\'=>\'GB1\',\'Supplement\'=>2);<br>".
"include(\'include/tcpdf/fonts/uni2cid_ag15.php\');</pre>".
"</li><li>".
"Korean :<br>".
"<pre>\$enc=\'UniKS-UTF16-H\';<br>".
"\$cidinfo=array(\'Registry\'=>\'Adobe\', \'Ordering\'=>\'Korea1\',\'Supplement\'=>0);<br>".
"include(\'include/tcpdf/fonts/uni2cid_ak12.php\');</pre>".
"</li><li>".
"Japanese :<br>".
"<pre>\$enc=\'UniJIS-UTF16-H\';<br>".
"\$cidinfo=array(\'Registry\'=>\'Adobe\', \'Ordering\'=>\'Japan1\',\'Supplement\'=>5);<br>".
"include(\'include/tcpdf/fonts/uni2cid_aj16.php\');</pre>".

Yes, I have downloaded it_IT_SuiteCRM_v7301.zip from that page.

After installation of the language must make the correction in modules / Configurator / language / it_IT.lang.php file as I wrote above.
I solved the problem in this way

I made the change but the problem remains

Hi, can you please report the error you see in the apache log?

I attach the correct file.

Extract and replace it with what’s in your path /modules/Configurator /language/
It should work

Thanks
Please join in and translate that key and others for your language!
https://crowdin.com/project/suitecrmtranslations