Blank Screen after upload

Hi All

i could not do an automatic upgrade to 7.2 from 7.1. The System Check, was fine but after uploading the Admin - UpgradeWizard Screen was blank. After resetting permissions, rewriting the php and following every tip I could find, I gave up and just did a manual install.

I am now trying to upgrade from 7.2.0 to 7.2.1 with exactly the same problems.

I have 2 questions
What is causing this and how can I correct it?
Can I just manually overload the new files using FTP for this particular upgrade

This sounds like a server specific issue so you would need to detail your full set up, what your php.ini settings are, etc.

Hi Will

What specifically would I need to provide php.ini - what else?

Here is my php.ini - which is in the root of my CRM install

memory_limit = 512M
upload_limit = 254M
upload_max_filesize = 254M
post_max_size = 254M
safe_mode = off
date.timezone=“UTC”
error_reporting = E_ALL | E_STRICT
log_errors = On
display_errors = Off
error_log = /php-errors.log
allow_call_time_pass_reference = Off

All settings should accommodate the upgrade file.

Do you get any errors in your log or php errors in the php error.log when uploading?

If you turn on displaying errors in your php.ini/index.php of the CRM, is an error message shown when the white screen appears?

Thanks,

Will.

Hi Will

I have enabled errors, I have also checked the logs and no luck.

It appears that the second there is a .zip file in the patch folder the Upgrade Screen is blank. The second I delete the zip folder I can then access the Upgrade Wizard.

If I create a custom module and publish it so that it creates a manifest and zip file, then my Upgrade Wizard Screen goes blank until I delete the zip file. so it somehow appears that it is due to the zip file. Does that make any sense?

I recomend to do these things:

1-) Never use a language pack for upgrading the system, always activate the defailt english and use that language to do system stuff
2-) Never upload a file with spaces, edit them and remove all spaces
3-) While you’re in upgrading process, before, and each time you make a click, run these commands:
Set the following permissions on the SuiteCRM directory(Linux):
sudo chown -R www-data:www-data .
sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload config_override.php
4-) Maybe the zip file is corrupted, just download it again and try

With the years using SugarCRM and now SuiteCRM those are best practices for me when making an upgrade

Best Regards

1 Like

Hi Mike

I have tried all of these options except No 3: - I have just used my cPanel to Recursively set permissions.

Any other ideas?

I was unable to resolve this problem so I did a full install of 7.2.1 via FTP upload and Fresh Instance install. Lost all my customisation - live and learn