Blank Page When Install Suitecrm 8.1.2


I’m trying to install SuiteCRM 8.1.2 on Linux Mint but kept getting a blank page.

When I tried to install using the CLI, it said that

Upload File Size | error | Warning: Your PHP configuration should be changed to allow files of at least 6MB to be uploaded

I was able to install on Windows 10 using XAMPP with this method

However I’m still wasn’t able to install to Linux

Steps when I installed

  • Move suitecrm folder to /var/www/html/
  • cd /var/www/html/suitecrm then put these in

find . -type d -not -perm 2755 -exec chmod 2755 {} ;
find . -type f -not -perm 0644 -exec chmod 0644 {} ;
find . ! -user www-data -exec chown www-data:www-data {} ;
chmod +x bin/console

  • Browser localhost/suitecrm. It showed a index of /suitecrm

  • click on public folder and it becomes a blank page

  • Create suitecrm database, the page is still blank

  • Tried using cli. It gives this error

Upload File Size | error | Warning: Your PHP configuration should be changed to allow files of at least 6MB to be uploaded

  • the php.ini file has upload_max_filesize at 60M

Please help


Check the post_max_size as this setting affects and limits the file upload.

I would also verify the upload_max_files the server allows for this account were you are installing SuiteCRM.

I changed both to
post_max_size = 100M
upload_max_filesize =100M

But still giving me error when install.

With install page = Blank page


Upload File Size | error | Warning: Your PHP configuration should be changed to allow files of at least 6MB to be uploaded.


For your CRM, go to admin > diagnostic > phpinfo to find out the effective php.ini for SuiteCRM as mentioned here:

Then check the limits impose by the server where the account is hosted.

I suggest to check each php.ini value in the account and the server for any value equals to 6MB. Then, increase the value.

Ok I updated the php.ini in cli folder

./bin/console suitecrm:app:install -u “admin” -p “password123” -U “root” -P “password123” -H “” -N “suitecrm” -S “” -d “no”

SuiteCRM Silent Install

Running: check-install-lock
step: check-install-lock | status: done
Installer not locked. Proceeding with install
Running: check-db-connection
step: check-db-connection | status: done
DB credentials ok
Running: install-system-checks
step: install-system-checks | status: done
Running: create-config
step: create-config | status: done
Created silent install config: config_si.php
Running: create-env
step: create-env | status: done
Created .env.local
Running: run-legacy-install
step: run-legacy-install | status: done
Legacy install successful


When I tried to open = I’m still seeing the index page. When clicked on public folder, the page is blank still.

@cornutaurus Let’s see if someone else has encountered and recognize your issue in order to help you from here.

Do I need to install Suitecrm 7.12 before Install Suitecrm 8.1?

Or is suitecrm 8.1 is a stand alone app?

When I upgraded from a SuiteCRM version 7.x to v8.

  1. I backed up my previous version.
  2. I downloaded version 8.1.2 zip file from here. Download - SuiteCRM
  3. I uploaded the backup database and adjusted folders and file permissions.

SuiteCRM 8.2 just came out and it’s the first version with an upgrade-path from v7 to v8 (and it’s still pre-release, meaning, you need to test thoroughly and be careful).

It is not recommended to try any sort of manual upgrade from v7 to v8 without the actual upgrade script provided in 8.2 and newer.

Of course, any v8 version can be installed initially without any previous installation, that is actually a much simpler scenario.

I’m install v8.1.2 on a fresh install. And I haven’t been able to install it. It keeps giving me a blank page.

I tried to go to localhost/suitecrm/public/legacy and was able to pull up the install page.
Everything worked after installing via /legacy/install.php but I have to go to localhost/suitecrm/public/legacy to log in.

Can I just move all the files under /public/legacy to /public?

No, sorry.

You really have to get the web server and htaccess configurations right, and the ownership/permissions right, and then go through the installation manual as it is written. The ways around that you are describing will not work.

i also have same issue for SuiteCRM8.3.0 and i have resolve this by first, to enable mod_rewrite, and then write sudo nano /etc/apache2/apache2.conf
it will show you this:

<Directory /var/www/>
        Options Indexes FollowSymLinks
        AllowOverride None
        Require all granted

change AllowOverride None to AllowOverride all , then your issue of SuiteCRM 8 having blank page will be resolved!!

1 Like


Thank you.

I did a different way

sudo nano /etc/apache2/sites-available/000-default.conf

<Directory /var/www/html/espocrm/>
Options Indexes FollowSymLinks
AllowOverride All
Require all granted
</ Directory>

I think your way is easier.

Could you show me the steps you did to install on Ubuntu?
I had a problem when editing fields

I want to compare to how other people are doing it.


it is not related with your editView issue, this configuration allows directory listing, enables the use of .htaccess files for overriding settings, and grants access to all users for the “/var/www/html/espocrm/” directory.