Make a quick vote 🗳 ️How do you refer to SuiteCRM extensions: add-ons or plug-ins? Click here to have your say 👈

Blank Page When Install Suitecrm 8.1.2

Hello,

I’m trying to install SuiteCRM 8.1.2 on Linux Mint but kept getting a blank page.

When I tried to install using the CLI, it said that

Upload File Size | error | Warning: Your PHP configuration should be changed to allow files of at least 6MB to be uploaded


I was able to install on Windows 10 using XAMPP with this method

However I’m still wasn’t able to install to Linux


Steps when I installed

  • Move suitecrm folder to /var/www/html/
  • cd /var/www/html/suitecrm then put these in

find . -type d -not -perm 2755 -exec chmod 2755 {} ;
find . -type f -not -perm 0644 -exec chmod 0644 {} ;
find . ! -user www-data -exec chown www-data:www-data {} ;
chmod +x bin/console

  • Browser localhost/suitecrm. It showed a index of /suitecrm

  • click on public folder and it becomes a blank page

  • Create suitecrm database, the page is still blank

  • Tried using cli. It gives this error

Upload File Size | error | Warning: Your PHP configuration should be changed to allow files of at least 6MB to be uploaded

  • the php.ini file has upload_max_filesize at 60M

Please help

@cornutaurus

Check the post_max_size as this setting affects and limits the file upload.

I would also verify the upload_max_files the server allows for this account were you are installing SuiteCRM.

Hello,
I changed both to
post_max_size = 100M
upload_max_filesize =100M

But still giving me error when install.

With install page = Blank page

CLI

Upload File Size | error | Warning: Your PHP configuration should be changed to allow files of at least 6MB to be uploaded.

@cornutaurus

For your CRM, go to admin > diagnostic > phpinfo to find out the effective php.ini for SuiteCRM as mentioned here:

Then check the limits impose by the server where the account is hosted.

I suggest to check each php.ini value in the account and the server for any value equals to 6MB. Then, increase the value.

Ok I updated the php.ini in cli folder

./bin/console suitecrm:app:install -u “admin” -p “password123” -U “root” -P “password123” -H “127.0.0.1” -N “suitecrm” -S “http://127.0.0.1/suitecrm” -d “no”

SuiteCRM Silent Install

Running: check-install-lock
step: check-install-lock | status: done
Installer not locked. Proceeding with install
Running: check-db-connection
step: check-db-connection | status: done
DB credentials ok
Running: install-system-checks
step: install-system-checks | status: done
Running: create-config
step: create-config | status: done
Created silent install config: config_si.php
Running: create-env
step: create-env | status: done
Created .env.local
Running: run-legacy-install
step: run-legacy-install | status: done
Legacy install successful

============

When I tried to open
127.0.0.1/suitecrm = I’m still seeing the index page. When clicked on public folder, the page is blank still.