blank page when creating PDF Template


I just installed the version 7.10.2 SUITE CRM which is hosted at OVH.
I installed existing PDF models and also created my own templates.
I have a blank page when creating the PDF TEMPLATE

I tried to rebuild the files, but I still have the same error log :

Sun Apr 15 18:12:03 2018 [26340][1][FATAL] Exception handling in /home/eagleman/suitecrm/include/MVC/Controller/SugarController.php:402
Sun Apr 15 18:12:03 2018 [26340][1][FATAL] Exception in Controller: Invalid Module
Sun Apr 15 18:12:03 2018 [26340][1][FATAL] backtrace:
#0 /home/eagleman/suitecrm/modules/AOS_PDF_Templates/formLetterPdf.php(50): sugar_die(‘Invalid Module’)
#1 /home/eagleman/suitecrm/include/MVC/Controller/SugarController.php(1014): require_once(’/home/eagleman/…’)
#2 /home/eagleman/suitecrm/include/MVC/Controller/SugarController.php(465): SugarController->handleEntryPoint()
#3 /home/eagleman/suitecrm/include/MVC/Controller/SugarController.php(373): SugarController->process()
#4 /home/eagleman/suitecrm/include/MVC/SugarApplication.php(109): SugarController->execute()
#5 /home/eagleman/suitecrm/index.php(52): SugarApplication->execute()
#6 {main}

THX for your help

That link seems to be missing a module name…

Can you please provide the exact steps to reproduce? Which screen do you visit, where do you click?

You can also try it in the live demo

Hello & Thx for your reply.

My steps :

1- In the ACCOUNTS section, I selected a customer by clicking in the check box.
3- A window pop up opened, I clicked on a Template

Then, a new web page turns in a loop (Blanck page) :

*** I tested the demo account ( ), repeating the same steps, and I was able to generate a pdf document (see attachment).

Thx for your help

If it works on the demo, we need to understand what is different in your installation.

Maybe simply upgrading to 7.10.4 will fix it.

If not…

Do you have any customizations or add ons?

What does the URL look like on the demo, does it have a “module=accounts” variable?

I encountered this problem with the installation of version 7.10.2

Being in startup test, I have everything re-installed this morning with version 7.10.4, and I encounter exactly the same problem.

I have no customizations or add ons for now

On the demo website, the url address is :

I looked in the configuration of the user interface in AJAX, all the modules are activated for me.

I’m sorry, I don’t know what else I can recommend, except full debugging of the issue, if you are able to do it: checking the variable values when the error occurs, or stepping through the code…

If you can’t do this you can try opening an Issue on Github, but if the developers try to reproduce and can’t, they’ll just close it.

Do as you prefer. Thanks

As the installation is recent and with the right files, and no other module added, I wonder the compatibility of version 7.10.4, of SUITECRM with my hosting at OVH.

Can you please tell me the prerequisites for installing suitecrm at a host?

I have the following versions :




This is the compatibility matrix:

The Installation Guide also lists a few PHP modules that are required:

However, it’s very rare for a hosting to be incompatible with SuiteCRM. Normally it’s just a matter of getting the configuraitons right: file permissions, PHP modules and php.ini settings.

Your case doesn’t look like a hosting problem to me, it might be a bug or something peculiar about your template.

Can you try recreating the PDF Template, and making sure it si for the “Accounts” module?

(BTW I tried reproducing your bug in my 7.10.4 and it works well, no bug)