Blank error popup when importing from Excel worksheet

Hello, I have spent the last week setting up a SuiteCRM instance in my office server, it is currently up and running and it is VERY fast. I setup all my custom fields, disabled salutation, fixed the contact screen to my liking, etc. Now I am trying to import all of my contacts, which are on an excel sheet I had to automatically/manually modify to be able to import each field into SuiteCRM.

When I download the template from SuiteCRM to paste my own data to each column and be able to import it correctly, when I click “IMPORT”, it takes me thought the regular fields, checking the fields, duplication tabs, etc…at the end, when i click “Import” or “Next”, a blank “Error” little window pops up, it has an OK button and a (X) Close button. I checked the logs and it didn’t show any relevant info.

The list is about 12000 rows, I have tried to import 1000/500/100/10. But theres is somethingf funny, it always imports the first contact PERFECTLY (all the fields info where they should be), but no more than that.

Anybody can help me please? I need to set that up and have it working.

BUMP? Anybody?

I assume that you mean import from csv file, since SuiteCRM does not import directly from excel.

Having said this there are several things that may occur.

For example: badly formatted data.

One common problem arises if your data contains quotes or double quotes.

Personally I first normalise the data using excel. Once done I open the file with LibreOffice and convert it to csv from there (when I do it with excel it fails most of the times).

Importing less lines may not solve your problem if the error occurs in the beginning of the file that you are trying to import so you could try removing, say the first 100 lines and try. This will help you isolate the problem.

Thanks for the reply, yes its a .csv made with MS Office 2016 after I normalized all the data. I think the issue is what you said (me using Excel instead of LibreOffice after normalization). I will now use LibreOffice to save the .csv and try that. Will keep you posted.


If your problem is just Linux vs Windows line endings, you can use Notepad++, a much lighter tool, and one that exists on portable version (as in

It is quite good to handle all these line endings issues (to know which ones are in the file, and to save with different terminations.

Since you say your first record gets imported correctly, I thought it could be a line termination problem.

Hi again, I turned on the erros displays and saw this where the usual BLANK popup wold appear:

Fatal error: Call to undefined function iconv() in /usr/local/www/apache24/data/suitecrm/modules/AOD_Index/Lib/Zend/Search/Lucene/Field.php on line 222

How can I fix that?

I managed to find the solution, the problem was that I had to install ivcon for php56. Im using FreeNAS and i had to pkg install php56-ivcon and extras. After that I was able to import the contacts, although I had to do it 1000 at a time, and the progress bar never moved past “Importing Records 1 to 1001 of 1001”
It worked perfectly, so yeah. Thanks for the help guys.