Blank Admin Area

On my test machine I’m running SuiteCRM v7.6 Beta 2. I would like to upgrade it to the latest version to make sure everything works before I upgrade my production server. Unfortunately, I am unable to do this because when I attempt to access the Admin area, all I get is whitespace under the “Administration” header. The top level menu is visible, just none of the links in the body of the page are there.

I have checked both the Apache logs and the sugarcrm.log files but don’t see any errors that would clue me into what’s happening. I have restarted Apache, rebooted the server, updated the server (using apt-get dist-upgrade)…all to no avail. Has anyone run into this problem?

This happened randomly of you did something to triggered? like an update or something? try to paste this in your browser


you probably will get a warning “Possible Cross Site Request Forgery (XSRF) Attack Detected” in that webpage click in “Click here for directions to add this site to the acceptable referer list” and will display instructions to accept that.

There you will have the repair option of SuiteCRM, try to repair your instance and then test again, remember to remove the steps you did above.

Best regards

Thanks for the assist Mike. I did as you instructed and it appears the repair started, but has been stuck at “Rebuilding Relationships” for about 10 minutes now. That doesn’t seem normal to me - no?

now try to check your logs, I’ve seen that kind of behavior before and it was because of a bad upgrade, I had to revert to a previous state(thanks to virtualization).

best regards

This is the only error I’m seeing in the sugarcrm.log file whenever I invoke the repair utility directly via the url you provided:

Thu May 19 13:59:03 2016 [3333][1][FATAL] Job a93a44ef-3c56-7201-cdcb-573dfe721a3e (Perform Lucene Index) failed in CRON run


Go to Admin section and DISABLE AOD :wink:

I think, there was a problem with php module iconv.

Oups, read, you must go to admin section to do that… maybe another way is config.php

This is the a part of config_override.php

$sugar_config['stack_trace_errors'] = false;
$sugar_config['developerMode'] = false;
$sugar_config['aod']['enable_aod'] = false;

Then make a repair with url above.

thanks for the assist, but still no luck. The repair stops at “Rebuilding Relationships” :frowning:

Hum, another problem then. Put this (sorry, i try)

$sugar_config['developerMode'] = true;

you have certainly php error or apache error … without log, we can not be helpful.

no difference. I’m willing to share logs, which ones should I post?

php log
you have i think a bad file (bad char) in metadata (relationship file)…
you must check theses files.
sorry, can t help more (no senior skill)

no worries item, you’ve been helpful. I’ll keep digging

I solved my own problem. Turns out the SuiteCRM installation itself was bad. Anyway, for anybody else experiencing this problem, here’s what I did:

  1. I enabled errors by adding the following to the top of my index.php file: ini_set(‘display_errors’,1); … be sure to remove it afterwards
  2. I then saw a fatal error that pointed to an undefined function Basic on one of my custom modules. Interestingly, I got a similar error when I tried to run the Quick Repair & Rebuild, but it was for another non-custom module, however, on the same line# 67.

So to resolve the problem, you need to change ALL occurrences of