Bad data passed in; When trying to forward or reply to emails

Fresh installation of SuiteCRM 8.0.1 and everything else seems to be working correctly. However after I have imported an Email, whenever I open up the actual Email record and hit Reply, Reply to All or Forward, I get the “Bad data passed in; Return to Home” error.
When I go composing a new email or when I hit Reply from the Email Dashlet without actually opening up the Email record, it works without issues.

I have double and triple-checked permissions, have done numerous Quick Repairs but no luck.
The only thing I see in my apache logs is this:

PHP Notice:  Undefined index: Emails2_EMAIL_offset in /var/www/html/suitecrm/public/legacy/modules/Emails/include/ListView/ListViewDataEmailsSearchOnIMap.php on line 125, referer:
PHP Notice:  Trying to get property 'isgroup' of non-object in /var/www/html/suitecrm/public/legacy/include/SugarFolders/SugarFolders.php on line 790, referer:

Hi @Rait,

Thank you for the feedback.

Could you create an issue in SuiteCRM-Core project in github please? I don’t recall seeing this issue before.

Thank you

Hello @clemente.raposo,

thank you for responding.

I wanted to rule out the possibility of this being a known issue with an existing fix. I have now created the issue on Github as well.

1 Like

Hi @Rait,

Thank you!

Has there been any updates on this issue? I am running 8.1.2 and I’m seeing the same issue when I reply to an email I get the same error

Hi @jbourque,

Welcome to the community :wave: .T hank you for the feedback. Yes this issue has been fixed. It has been included in version 8.2.0.

The following is the reference to the github issue

PS: I may not be able to reply back.

Thanks for the info. I applied the updates as referenced in the change. and removed &return_module=Emails&return_action=index from each line and it still returns the same error.

Hi @jbourque,

Did you run “Repair and Rebuild”?

Also, check if you have a copy of the file in public/legacy/custom/modules/Emails/metadata/detailviewdefs.php

Hope this helps

Looks like the repair and rebuild fixed it.

Thank you