Automatic opt in only for webforms?

I went to mail settings and enabled double opt in and checked the box to automatically send opt-in mails. But what I noticed: this opt in mail is only being sent when I create contacts/leads via the webform. It is not working when manually adding records. I tried to create these contacts with the very same values as in the webform, and I played around with the buttons next to the mail address (“opt in” checked while creating and unchecked).
What do I miss? Can someone help me on this? thanks!


actually no one using the (double) opt in who has experience with setting it up?