Authentication not possible using SAML with Auth0

These are the logs when I try to authenticate the user with auth0:

Mon Dec 21 12:16:49 2020 [5396][-none-][FATAL] SECURITY: User authentication for admin failed
Mon Dec 21 12:16:49 2020 [5396][-none-][FATAL] FAILED LOGIN:attempts[1], username[admin]
Mon Dec 21 12:16:53 2020 [5396][-none-][FATAL] SECURITY: User authentication for admin failed
Mon Dec 21 12:16:53 2020 [5396][-none-][FATAL] FAILED LOGIN:attempts[1], username[admin]

Auth0 lets me through (the auth0 logs says user login successful) but I have to login again from the crm login page to enter.

I’ve been scouring the forum for help with this, but I haven’t found anything that fixed it. I did try the advice on this page : (it basically tells me to make a modification to the SAML2AuthenticateUser.php file and enable saml external authentication in the user’s profile) but this creates another problem. It says that the user has logged out and I have to login again. Clicking on login refreshes the page and says that the user has logged out again.

Additional information : Bitnami stack installation for the latest version of CRM, server running on Windows 10. There is no permission issues or any other issue with the running of the CRM, just this authentication problem.

Could anyone please help me out with this? Thank you.

Try with a simpler password, no weird characters. Just as a diagnostic.

1 Like

The password was just alphanumeric, no special characters. Anyway I changed it to just alphabets, but still no luck. It says logged out. I had to disable saml authentication in the db for the user to be able to log back in.

1 Like

I’m sorry, but is there any other way I can fix this? I sure would appreciate any help.

The problem is me - I don’t have much to give to this thread, unfortunately. I’ve never used SAML and I am not familiar with these features in SuiteCRM.

I was hoping someone else would come here and help you out - meanwhile I just had that small suggestion about the characters in the password (because of a similar issue I once saw).


The simpler password worked for me. Thank you!

Can you please file a new issue on Github saying that some passwords break the authentication? Preferrably, includeing a specific made-up password that causes the bug.