Apache is looking for files that doesn't exist

Exporting a report with 48000 to csv is taking too long. We detect in the server that is apache that is consuming cpu. is trying to open files that doesn’t exist.
I’m missing any configuration?




This is temporary files to make html pages. I doubt that it associated with csv file. May be it’s different problems.

1 Like

Looks like left-overs from some custom module, although I have no idea why they’re getting loaded there…

1 Like

I have created a include folder in custom folder to make changes and be upgrade safe.
So inside this custom/include folder I’ve putted the files that I needed to change.
I realize now that some files apache is searching are files from the original folder but is looking in custom/include so it throws the error.

How can I avoid this?

in your SuiteCRM root directory, run

grep -irn InvoicePlan .

This should show which files contains references to the missing files.

I see another forums. May be you the problem is related to configuration of proxy on apache server.

This error only ocurrs when I’m exporting the report like I said.
Probably is not a coincidence but the name of the files that is looking for and don’t find is the name of the module + DetailView + the name of the column that is configured to show in the report.


I realize now that suitecrm is creating tpl and put them in the cache folder.
But why is he searching in a bunch of different places? That’s why I got lots of messages saying File not found.

access("/var/www/html/SuiteCRM/themes/SuiteP/cache/modules/AOW_WorkFlow/ptin_InvoicePlansDetailViewassigned_user_name.tpl", F_OK) = -1 ENOENT (No such file or directory)
access(“custom/cache/modules/AOW_WorkFlow/ptin_InvoicePlansDetailViewassigned_user_name.tpl”, F_OK) = -1 ENOENT (No such file or directory)
access(“cache/smarty/templates_c/%%50^50A^50AC3DE1%%ptin_InvoicePlansDetailViewassigned_user_name.tpl.php”, F_OK) = 0
access("./cache/modules/AOW_WorkFlow/ptin_InvoicePlansDetailViewassigned_user_name.tpl", F_OK) = 0
stat("./cache/modules/AOW_WorkFlow/ptin_InvoicePlansDetailViewassigned_user_name.tpl", {st_mode=S_IFREG|0755, st_size=140, …}) = 0
access("./cache/modules/AOW_WorkFlow/ptin_InvoicePlansDetailViewassigned_user_name.tpl", R_OK) = 0

You wrote:

It’s error of apache but not SuiteCRM. May be it’s problem with .htaccess file?

Despite of apache is looking for file that doesn’t exist is not that that is taking time consuming.

Is the call of getModuleField function in function build_report_csv that is taking all that time.

The report that I was testing has a lot of related column but that shouldn’t be the justification for bad performance of this module.

Try running the first query on this post to check for overgrown tables in your database:

You can also turn on Log slow queries in Admin / System Settings and check your logs if you have database problems.

Other than that, you could be getting underlying issues that cause a slow down: corrupted files, a disk sector that is burned out, etc.

1 Like