Apache error message when installing Suitecrm8

Hello Forum.
I am trying to install Suitecrm 8.5 but hit a snag with Apache
I get the error message:
Cannot serve directory //wolar_crm/: No matching DirectoryIndex (index.html,index.php,index.cgi,index.php,index.php) found, and server-generated directory index forbidden by Options directive

I checked my apache.conf file, and I think it is set correctly:

DirectoryIndex index.html index.php index.cgi

I run under
PHP 8.2.14
What am I missing?

Thanks for helping.


You need to configure URL re-writes for it to work:

Thanks for picking this topic up.
I followed the guide. mod_rewrite is loaded on my server.
For fun I install 7.14 and that works perfectly fine. What is the different btw 7.14 and 8.5 as it relates to the webserver?


Did you set the webroot correctly?

For v8, that should be the /public directory, not the top directory.

What does your apache virtualhost section look like?

Yes, I did set the webroot with the same config as described in SuitCRM installation guide
I also copied SuitCRM 7.14 config into a new file and changed the paths to public.
I still get the error message.


But your error says otherwise :point_up: , it should be trying to serve (probably) //wolar_crm/public

It’s just saying it can’t find the index.php in your web root, so check your web root (reastart web server), and check that your web root has an index.php file.

I started from scratch again and are a step further.
Initially I received the same Cannot serve directory again. I tried then to install with CLI installer.
As you see I get a failed message: step: install-system-checks | status: failed
And installer complaints about upload_max_filesize. I checked my php.ini and value is set to 256 MB!
Interesting enough, I now can access the installation screen via the webinstaller, but don’t get passed first page. No error message is shown, just an empty red status bar at the top.

DataBase User name, Database Name and Admin Name were deleted on purpose before the screenshot

How do I go from here?

Thanks, Wolfgang

There are two relevant php.ini’s

One for the web server, one for CLI (command-line).

In the command-line, type

php -i | grep php.ini

to know the file path you need to edit.