AOD doesn't work!

I have a very strange situation, which I can’t solve.
I have 2 instances of SuiteCRM running on the same server. Same version 7.4.3.
Both are configured to use the AOD indexing. On one instance the indexing is running and the tasks lucene index and optimise AOD index run fine.
The other instance (‘exactly’) the same, the index and the tasks aren’t. I reset all permissions again and looked at potential differences between the 2 instances.

The only thing I could find, and probably the cause of this strange behavior, is that the SchedulerVardefs.php in …/cache/modules/Schedulers is different.
The difference is the rights setting. On the instance where it functions well it is 775 as you may expect after resetting the permissions.
BUT on the instance where it doesn’t run the rights setting is al of a sudden 655, without doing anything and forced the same reset of the permissions.
I just ran a new permissions reset and again the setting changed from 775 to 655. I saw now that also SchedulerJobVardefs.php in directory SchedulersJobs has the same, from 775 to 655

What is wrong? The other instance doesn’t have this and has the same configuration.

Please assist!