AOD - Advanced Open Discovery - Not displaying records that are found under "Use standard SugarCRM search"


I upgraded my local copy of Suite CRM 7.0 to 7.1 and have the AOD checkbox checked in settings.
When I type in a contact first name, or the first part of an account name I get no results.
When I click on “Use standard SugarCRM search” then I find my records.

Is there any other configuration required or is it working for others in the release Build? - Downloaded it from your website.
I would have put this under the Suite CRM 7.1 category - but there is not one yet :slight_smile:


Hi Bill,

There isn’t any extra configuration other than ensuring that the AOD schedulers are running (although it may take some time for these to run and index the records on larger databases). If these are running then there may be something up.



So are these the two scheduler tasks?

Perform Lucene Index
Optimise AOD Index

Check your permissions after installation. Topic #3660 is a reference and I believe possibly the same thing you are experiencing.


Hi Bill,

Yep those two tasks help keep the index up to date.



To rebuild the Index, delete the Index directory in /modules/AOD_Index and clear the records in aod_index and aod_indexevent. Then your scheduled jobs will rebuild the Indexes (Indices?).

But don’t do it unless you’re very comfortable with SQL, etc.

Suggestion: Automating the Rebuild would be great to have under AOD Options.