Am facing issues while installation

Hi SuiteCRM Silent Install

Running: check-install-lock
step: check-install-lock | status: done
Installer not locked. Proceeding with install
Running: check-db-connection
step: check-db-connection | status: done
DB credentials ok
Running: install-system-checks
step: install-system-checks | status: failed
PHP Version | success | 8.1.26
PCRE Library | success | 10.39 2021-10-29
XML Parsing | success
JSON Parsing | success
MB Strings Module | success
Writable Upload Directory | success
Sprite Support | success
ZIP Handling Module | success
Writable Cache Sub-Directories | success
Writable Modules Sub-Directories and Files | success
Writable SuiteCRM Configuration File (config.php) | success
Config override | success
Writeable Custom Directory | success
ZLIB Compression Module | success
cURL Module | success
IMAP Module | success
Upload File Size | error | Warning: Your PHP configuration should be changed to allow files of at least 6MB to be uploaded.
PHP Memory Limit | success | OK (Unlimited)

ui not loading

1 Like

Can you let us know what your file permissions are set to?

With the ui not loading it suggests to me it’s a file ownership issue.

Check there first - as the command line installer is reporting all OK.

now the issues fixed but what was default url
installation were done by cli
installation successful but what is the url to login in admin

Hello @Anandh,

Here’s the URL to access the login page:

If you have any questions or encounter any issues, feel free to reach out.

Oops! An Error Occurred

The server returned a “500 Internal Server Error”.

Something is broken. Please let us know what you were doing when this error occurred. We will fix it as soon as possible. Sorry for any inconvenience caused.

Okay @Anandh

Check your site_url in the config.php file.

exact path pls
i couldnt find the path

Okay @Anandh

Here is the path for suitecrm 8 : public/legacy/config.php

yes but its correctly only like this

seems no issues in the installation

array (
‘dir_mode’ => 02755,
‘file_mode’ => 0644,
‘user’ => ‘’,
‘group’ => ‘’,

is this permission correct in config.php

Fix the default_permissions setting in 3 places:

‘default_permissions’ => array (
‘dir_mode’ => 02755,
‘file_mode’ => 0644,
‘user’ => ‘www-data’,
‘group’ => ‘www-data’,

./include/utils.php - in the function make_sugar_config() - line 138
‘default_permissions’ => array (
‘dir_mode’ => 02770,
‘file_mode’ => 0660,
‘chown’ => ‘www-data’,
‘chgroup’ => ‘www-data’,

./include/utils.php - in the function get_sugar_config_defaults() - line 264
‘default_permissions’ => array (
‘dir_mode’ => 02770,
‘file_mode’ => 0660,
‘user’ => ‘www-data’,
‘group’ => ‘www-data’,

fixed login with this but facing this issues

are you there
excuse me support team