Always redirect to Login Screen

I have a WordPress website installed into root of my shared server for example Now I have installed copy of SuiteCRM 7.3.1-Max on my localhost (on windows system with xampp installed). And it is working fine on my localhost. Than finally I copied the database and crm folder to my shared server into a new directory with name crm ( So when I try to login with any user account it redirects to the login screen. I am using the correct credentials and there is no errors/warnings on the page or into the log files of CRM. I guess there is something wrong with htaccess files. Attached are screenshots of my htaccess files of parent directory(where WordPress site is running) and child directory(where CRM is running). Also I looked into permssions, all directories have permissions 755 and all files have permissions 644 including cache.
Please help me.

WordPress folder’s htaccess file:

SuiteCRM folder’s htaccess file:

I notice you said the cache files have permissions 644. The files in the cache should be 775, everything else should be 755.

If you go into your suite directory at the command line and fun the following commands you should end up with the correct permissions which should hopefully fix your log in issues

cd yoursuitedirectory
sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload config_override.php

1 Like

thanks for quick reply, I am going to apply these.

It didn’t solve my problem. I have change permissions for cache directory but still the after login it is redirecting to the same screen.

I don’t think the wordpress htaccess file should cause any problems as it’s rewriting url’s that start index.php where as from what you’ve said the suite urls will start crm/index.php

The only two things I can think off is to make sure all the suite files are owned by the apache user/group and also check the config.php file in your suite directory and check the site_url setting is correct.

1 Like

Your RewriteBase value for the SuiteCRM .htaccess and Wordpress .htaccess are just ‘/’.

Certainly for SuiteCRM this should be ‘/yoursuitecrmdirectory’ for example: ‘/SuiteCRM’.

You should also ensure the ‘site_url’ in your config.php is correct.

Kind Regards,


1 Like

I have tried this and the site_url is also correct but still I am getting the same problem.