Ajax error after upgrade

Unfortunately after running the upgrade on SugarCRM 6.5.16 with no additional modules/plugins (there are only some custom fields and additional fields in the layouts) I get an error message when I click on the contacts link:

a pop up appears with two messages:

at the top it says:
“An error has occured”
“There was an error processing your request, please try again at a later time.”

while, in very small print, at the bottom:
“If this error persists, please have your administrator disable Ajax for this module”

I am attaching a screenshot.

Any ideas?

Thanks in advance!


Hi Aldo,

Please go to Admin -> System Settings -> Configure AJAX user interface and drag “Contacts” across to disabled, i.e. disable AJAX for the contacts module.

If this does not work, please confirm you have set the recommended permissions on your SuiteCRM instance:

sudo chown -R www-data:www-data .

sudo chmod -R 755 .

sudo chmod -R 775 cache custom modules themes data upload config_override.php



Hi Will,

thanks for the quick response.

I tried following the steps you proposed (see screenshots attached) and made sure to have the right permissions.

Unfortunately now this is what happens:
. when I click on Contacts I get a resulting blank screen
. now Accounts produces the same popup with the error message that Contacts had initially
. if I try to re-enable Ajax for Contacts, the new setting is not kept (although I made sure to save before quitting the Ajax settings page)

Hi amariussi,

So when you drag Contacts back over to enabled, it bounces back to disabled? Did you try Ctrl+F5 after you had set the correct permissions/disabled AJAX?



I hadn’t tried Ctrl-F5 but now I have but nothing happened.

This is what happens:
. From (Administrator -> Admin, then click on “Systems setting” then on “Configure Ajax user interface”) I drag contacts in disabled box
. I click save
. go to home
. from home I click on contacts and a blank page appears
. I edit the url and delete everything after index.php and load the index.php page
. the home page appears
. I go to (Administrator -> Admin, then click on “Systems setting” then on “Configure Ajax user interface”)
. I drag contacts back to the enabled box then I click save
. I click on Home
. from home I go again to (Administrator -> Admin, then click on “Systems setting” then on “Configure Ajax user interface”)
And here, to my surprise, Contacts is in the disabled box

I tried also resetting again the permissions but, still both errors persist.

I also tried a clean install of SuiteCRM 7.01 in a different directory and then cloned the instance of the database of the upgraded CRM (from SugarCRM 6.5.16 to SuiteCRM 7.01) into the newly installed SuiteCRM.
In this case the error has disappeared but I lost all the SuiteCRM interface and extra functionality like AOS. If I try to upload the upgrade from SugarCRM to SuiteCRM I get a message saying that the upgrade has already been performed and I am left stuck with SugarCRM 6.5.16!!!

I will keep trying and will post new findings. Any help will be appreciated!


Just a quick update to let you know that I sorted my problems out:

  1. Clean install of SugarCRM 6.5.16
  2. Cloned my old SugarCRM 6.5.16 DB and pointed it to the clean install of SugarCRM 6.5.16
  3. Upgraded the clean install of SugarCRM 6.5.16 (with my old DB clone) to SuiteCRM 7.01
  4. Updated all file permissions after the upgrade

… and now it seems to be all fully working!

A very special thanks goes to Will for his very professional, quick and kind help!!!


I have a similar issue. Could someone please help me out with this. Thank you in advance.
Issue: when the case module is being clicked, it shows a blank webpage with nothing in it.

Technology being Use: Mysql, SuiteCRM and IIS

Additional Information:
After clicking on the case modules, a pop up appears with two messages:
at the top it says:
“An error has occurred”
“There was an error processing your request, please try again at a later time.”
while, in very small print, at the bottom:
“If this error persists, please have your administrator disable Ajax for this module”
We then went to Administrator >> System Settings >> Configure Ajax User Interface and added the Case module to Disable modules. Since then it gives us the blank page when click on the case module. We tried to remove the cases module from the disable modules, the new changes are not kept.

Hi mahmed,

Have you set the recommended permissions on your IIS to ensure SuiteCRM runs correctly?



Thank you Will for the quick response. My root folder is CRM and have given a full access to IUSR. See the attached image. All other modules are working fine with no issue accept the Cases Module.

Hi Will, I hope you did not forget about me :frowning:

Hi mahmed,

Have you tried dragging the module to disabled in AJAX UI in Admin, navigated to the module, pressed Ctrl+F5, go back into Admin and drag Cases to Enabled, then go back and pressed Ctrl+F5 again? Does your error persist?



Hi Will,

Let me know if I need to push this into a new thread. I am having the same issue all of a sudden with any AJAX-enabled modules. The particular issue though seems to be the first time you move from a non-AJAX-enabled module to an AJAX-enabled module. I have tested this a few times now and can consistently reproduce the issue on my system by switching to from the PDF templates module (AJAX disabled) to the contacts module (ajax enabled). I tried this with a few different combinations and in reverse, and I was always able to break it.

When I look at the main error log for sugar, with full log gin on, I do not see any errors or info, or debug items that should be cause for any alarm, and certainly no fatal entries. I checked that the permissions were all set properly as discussed in the earlier posts, and can confirm that the modules all seem to work well as long as I don’t go outside the ajax-enabled modules.

This also only just started happening today on my server. The only changes that were made have been some imports of information and a few extra fields being added to the accounts module. I did a quick repair when I made these changes and rebooted the server for good measure and still am seeing the problems.

Any thoughts on this? I currently have disabled AJAX across the entire interface and everything is working fine. Would love to eventually add the AJAX back in though.

Thanks in advance for any help!

THIS my error…please help me


After disabling the ajax modules and re-enabling them, I recieve this message on the server :
Argument 1 passed to Reminder::isDecline() must be an instance of SugarBean, boolean given, called in
/modules/Reminders/Reminder.php on line 299 and defined in /modules/Reminders/Reminder.php on line 374, referer: http://************.com/index.php?action=ajaxui

I don´t know if it´s related to this problem but we in “Call” module the accounts assigned to some calls have dissapear.

Thanks in advance!

** We are running Versión 7.4.3 ( Sugar Versión 6.5.20 )

I am having the same problem as azucaquest.
After disabling ajax module , I cannot reenabling again and the same error is showed in logs

I have the same version 7.4.3


I am following this issue since 7.1.2 version up to 7.4.3. To re-enabling ajax module:

  1. Check config.php
// created: 2016-01-05 19:15:58
$sugar_config = array (
  'SAML_X509Cert' => '',
  'SAML_loginurl' => '',
  'addAjaxBannedModules' => 
  array (
    0 => 'SecurityGroups',

If you have in the array something more than 0 => ‘SecurityGroups’ (e.g. 1 => ‘Accounts’, 2 => ‘AOS_Products’) - delete this.

  1. Check config_override.php and delete the corresponding lines at end of file:
$sugar_config['addAjaxBannedModules']['1'] = 'Accounts';
$sugar_config['addAjaxBannedModules']['2'] = 'AOS_Products';

It works for me :slight_smile:

1 Like

This is most likely a bug in the Reminder module (/modules/Reminders/Reminder.php). Temporary solution - change line 299:

(!$checkDecline || ($checkDecline && !self::isDecline($relatedEvent, BeanFactory::getBean('Users', $current_user->id))))



Hi mkrawczyk,

I tried your two solutions:

The first one did not solve my problem because I dont have other options in my config.php except 0 => ‘SecurityGroups’

But your second one solved my problem. I modified /modules/Reminders/Reminder.php as you said and it has solved the problem

Thank you very much for your help

I just did this 7.4.3 upgrade and hit the same AJAX errors. Every module had to have disabled for AJAX.

This has also resulted in important information to be dropped from detail views. For example, list of Contacts, Leads, etc. under Accounts view. List of emails related to Account or Contact, etc.

I’m really starting to hate upgrading…

Refreshing the page (shift, reload) does not work without doing it first to the non-AJAX version, and again to the re-enabled AJAX version.