After upgrade to 7.10.3 I can not create a new module in module builder


after updating to version 7.10.3 I can not create a new module in module builder. I create the package, I select the type of module, when saving, it stays in saving … and it does not happen.

Could you please give me some idea of ​​the cause?

thank you very much.


Have you checked the suitecrm.log?

Also, anything in the apache log files?


I have the same problem

In the module builder, when we will include the package, after naming it and choosing the type of module to insert into the package, it does not save. It hangs on the screen of “loading”

What do you mean “hangs”? Is the screen grayed out so that you can’t click on anything?

Does the operation still work? I mean, does the change become effective?

And finally, what errors do you see in you logs?

Latch as in the attached image, do not leave it.
The operation does not end.

In the log the error is this:

Fri Apr  6 16:17:29 2018 [15988][1][FATAL] ERROR: rmdir_recursive(): argument cache/themes/SuiteP/modules is not a file or a dir.

Strange, I wonder if you still have some permissions issue. Have you set the default_permissions array in config.php?

Anyway, you can delete the entire “cache/themes” directory, it will get re-created. Maybe that solves your problem.

As soon as I saw the log I cleaned all the files from the cache directory, it still did not work.

They are set to dir 775 and file 664. It remains the same as the previous version.

Did you include ownerships? Can you post exactly what you have in default_permissions array in config.php?

There are 2 instances.
In an installation I have:

  array (
    'dir_mode' => 509,
    'file_mode' => 436,
    'user' => '',
    'group' => '',

and in another:

  array (
    'dir_mode' => 775,
    'file_mode' => 664,
    'user' => '',
    'group' => '',

Ok, you have a few problems there.

First, you should add the user and group names, to match the user your web server is running under.

Then, the numbers used in permissions are in Octal base. In PHP, the notation for Octal is to prefix a 0. So you need to write 0755 and 0644 for the numbers to mean the same thing as when you type them in a chmod command. For dir_mode I advise 2755 or 2775 to include the necessary sticky bits.

Sorry for the lack of knowledge. I made changes to the permissions but nothing happens. What do I have to put as a user? It would be a local installation and another web.
Another thing after always using this way, because only now this was generating problems? I mean, why would that be a problem?

Those settings only take effect sometimes (not always) when creating new directories. For example, after you delete cache/themes and it re-creates.

However, I am not saying they will solve your problem, I still don’t know what your problem is - we just need to fix one thing after another until we find out the real reason for the problem and it starts working…

The user name, you can get it from the Admin / Schedulers screen, when it advises which user you should create the crontab for - that is your web server user. This is also what you should be using in your “chown” command. You are probably already doing this correctly, otherwise you would be getting a lot more problems.

Still does not work.
Can not this be a version problem? Does anyone else have this problem besides @jrivas and I

I did a clean install of 7.10.3 and the problem persists. I opened a problem at if anyone can contribute.

I have the same problem.
Upgraded from 7.10.1 to 7.10.3 with
Here is no way to upgrade step by step with 7.10.2 and then 7.10.3

Also left sidebar in Administration section is absent.

I can create Package. It is fast.
When I try to create module in existant package or new package I have a problem.
It holds in process of creating…

But while I write this… It create new module in new package with Basic type.

I dont know how.
I try to do quick repair some times and it doesnt work.
Then I try to re-upgrade. Delete uploaded and upload new upgrade zip file.
The repair it. After some tries I start new package and module and it works for simple type.

I started new module in the same package with type Issue and it holds with window “Loading… In progress…” again.

I aware about mistakes in database after this issues.
How to check it? How fix uncomleted modules ?


I try add another one. I also add module with type Issue and it done.
But after that I try to add new module and it holds again.
It looks very unstable and unpredictable when it can be done and when not.

Sometimes when I click on icon to select a type of module screen drop back to packages list.
Unpredictable too. With text in fields and without it.

… continue
I try to select Type of module 1st and it works better… more often.
I have succes in types: basic, issue, file… other not.

Version 7.10.4 solves this for me

Hi. Thanks to SuiteCRM team for replies and very fast reaction.
I share my experience here.

  1. Left side panel in administrative are works well.

Simple quick test:
2. I can add module to existing package - tested only with one basic type module.
3. I can create new package.
4. I can add to new package all types of modules.

Also I still have issue when I select any type of module sometimes system drop me back to package page.
Guess it is JScript problem. I guess it happens when I wrote some in fields before. But I test it and it happens without some reason.

Other questions I saw in forum solved?

Great fast fix, thanks.

Can you post this information on the GitHub issue where this was (partially) solved? Assuming there is an issue there, and that you can find it… I hope so.