Advanced search SuiteCRM assigned to issue!

Hi Guys,

Don’t know if anyone else experienced that but I have noticed that suddenly Assigned to (which is a built in field from the system) field has switched from OR condition to AND. So let’s say you want to get multiple users with certain status or statuses, nope, they wont show, but if you do it one by one, you can get the records. How can I get previous functionality which was working few days ago according to one of users?

The only thing that I have done is added new custom field using Studio in advanced search panel of Accounts, then I remove it wouldn’t help, done some Repair options…nothing. Still when I looked further, this is happening in all modules when you try multiple search with Assigned to field.

SuiteCRM version is 7.8.8 and upgrade is not an option since we still need all three of the Suite themes.

Thank you in advance.

Best Regards,


Hmm never heard of this one @slavenglaafs but will take a look at replicating it now. Can you confirm your saying,

If you searched for records created on this date by this user you end up getting all records created on that date and all records by that user due to the condition being or?

Also are the old themes not in till 7.8.31? If so I would suggest the update.

Hmm, I actually never tried that search either, it was just brought to me by some colleague and then I tested.

Yes, If I search using Assigned To field which built in drop down from the system I wouldn’t get any records if I choose multiple users…If I choose just one of them, I can see that records exists.

Now, this comes in handy if you want to view let’s say all the clients for 3 specific users on one page and export it instead opening three separate tabs and querying and exporting clients per each user individually.

Hope this clarifies things a bit…how safe is to go from 7.8.8 to 7.8.31 since we have some custom modules installed and probably some custom coding too?

Custom modules should be fine, other code-modifications might not (it really depends on how you did it, there is a custom, upgrade-safe layer).
Anyways: always test upgrades in a second/test environment first.

What about querying multiple users on advanced search has anyone tried it?

Just to share that I have found what is the potential problem. Security Suite module 3.1.19 is creating a bug in advanced search and breaks Assigned to field functionality from default behavior, Just upgraded from 3.1.18 on a test version and the same problem started on that one too.

I have the same problem, once leads are assigned to a specific user… If i try the advance search with the assigned name… no leads show up… so the assigned search feature isnt working