Admin tool Repair and Database failure with USER table

Suitecrm Version 7.11.6: immediately after performing Repair -> Quick Repair and Rebuild -> CLICK (Done) and a small notice appears at the end, please guide how to fix it. A message has appeared, Database failure with USER table ?

Thanks !

[b]NOTE: any changes you make to the script in the textbox will be reflected in the exported or executed code.[/b]

/* Table : users */
/*COLUMNS*/
/*MISMATCH WITH DATABASE - first_name -  ROW [name] => 'first_name'  [type] => 'varchar'  [len] => '30'  */
/* VARDEF - first_name -  ROW[name] => 'first_name'  [vname] => 'LBL_FIRST_NAME'  [dbType] => 'varchar'  [type] => 'varchar'  [len] => '255'  [required] => ''  */
/*MISMATCH WITH DATABASE - last_name -  ROW [name] => 'last_name'  [type] => 'varchar'  [len] => '30'  */
/* VARDEF - last_name -  ROW[name] => 'last_name'  [vname] => 'LBL_LAST_NAME'  [dbType] => 'varchar'  [type] => 'varchar'  [len] => '255'  [importable] => 'required'  [required] => ''  */
/* INDEXES */
ALTER TABLE users   modify COLUMN first_name varchar(255)  NULL ,  modify COLUMN last_name varchar(255)  NULL ;

This is know issue, there is fix at github, quick fix can followed here.

https://stackoverflow.com/questions/56927850/suitecrm-7-11-6-installation-upgrade-issue

Yeah hope that it will soon have a solution, fix error at the user module.

This does not work for me.

I am still getting:

/* Table : users */
/COLUMNS/
/*MISMATCH WITH DATABASE - first_name - ROW [name] => ‘first_name’ [type] => ‘varchar’ [len] => ‘30’ /
/
VARDEF - first_name - ROW[name] => ‘first_name’ [vname] => ‘LBL_FIRST_NAME’ [dbType] => ‘varchar’ [type] => ‘varchar’ [len] => ‘255’ [required] => ‘’ */
/*MISMATCH WITH DATABASE - last_name - ROW [name] => ‘last_name’ [type] => ‘varchar’ [len] => ‘30’ /
/
VARDEF - last_name - ROW[name] => ‘last_name’ [vname] => ‘LBL_LAST_NAME’ [dbType] => ‘varchar’ [type] => ‘varchar’ [len] => ‘255’ [importable] => ‘required’ [required] => ‘’ /
/
INDEXES */
ALTER TABLE users modify COLUMN first_name varchar(255) NULL , modify COLUMN last_name varchar(255) NULL ;

Hello there !

I just updated from V.7.11.6 to V.7.11.8, everything updates are extremely long and take a long time to system check, compared to the older versions or updates until version 7.11.0 then showing that from version 7.11.3 to 7.11.8 the update is very bad, Suitecrm requires a strong server configuration and time_out too.

I don’t know which words to use, for the conflict between: database and vardefs, they cause the User module got NOTE, both Version 7.11.5 to 7.11.6 or I tried 7.11.6 to 7.11.8 to get this error (tested on Live_shared hosting and XAMPP - locall)

I present here the error of Version update 7.11.6 to 7.11.8 during operation: Quick Repair and Rebuild in Admin tool - please give me a guide, thank you very much.

Differences found between database and vardefs

The following script will sync the database structure with the structure defined in the vardefs. You have the option of exporting this script and then running it against your database using external database management tools, or to allow the administration module to run the script.

NOTE: any changes you make to the script in the textbox will be reflected in the exported or executed code.

/* Table : users */
/*COLUMNS*/
/* INDEXES */
/*INDEX MISMATCH WITH DATABASE - idx_user_name -  ROW <name> idx_user_name <type> index <fields>[0] => 'user_name'  [1] => 'is_group'  [2] => 'status'  [3] => 'last_name'  [4] => 'first_name'  [5] => 'id'  */
/* VARDEF - idx_user_name -  ROW<name> idx_user_name <type> index <fields>[0] => 'user_name'  [1] => 'is_group'  [2] => 'status'  [3] => 'last_name (30)'  [4] => 'first_name (30)'  [5] => 'id'  */
ALTER TABLE users   DROP INDEX idx_user_name,  ADD INDEX idx_user_name (user_name,is_group,status,last_name (30),first_name (30),id);

@hoasenvang7799 I don’t think we changed anything about the upgrade process that would make it slower… maybe it’s your system that now has a lot more data in it than before? Do you experience slow query times?

About the vardefs sync problem, what happens when you press the button to run the script? And have you tried running it directly from phpMyAdmin?

Oh yes, I am running with 1 admin and 3 users, I see that there is not too much data, only at most the product images in the upload floder and with in upload floder / upgrades / patch folder there are a lot of existing old version (restore) delete is good solution to free up storage space.

As I wrote the comment above, updating on live_shared_hosting is very difficult (503 / Time_out often), … VPS / Dedicated Server, I can not operate, so updating with Xampp at loacalhost is a better solution.

Yes, 3 way :

  1. press EXECUTE button and the note said “Database tables are synced with vardefs”
  2. EXPORT button to .sql file and Import by phpMyAdmin control to database
  • it’s said first line “Import has been successfully finished, 1 query executed.”
  • but this is result with the second line " MySQL returned an empty result set (i.e. zero rows). (Query took 0.0095 seconds.)"
  1. go to Table: users and import .sql - the table said “SAME 2”

no change ! And NOTE again with “Repairs and rebuilds”

/* Table : users */
/*COLUMNS*/
/* INDEXES */
/*INDEX MISMATCH WITH DATABASE - idx_user_name -  ROW <name> idx_user_name <type> index <fields>[0] => 'user_name'  [1] => 'is_group'  [2] => 'status'  [3] => 'last_name'  [4] => 'first_name'  [5] => 'id'  */
/* VARDEF - idx_user_name -  ROW<name> idx_user_name <type> index <fields>[0] => 'user_name'  [1] => 'is_group'  [2] => 'status'  [3] => 'last_name (30)'  [4] => 'first_name (30)'  [5] => 'id'  */
ALTER TABLE users   DROP INDEX idx_user_name,  ADD INDEX idx_user_name (user_name,is_group,status,last_name (30),first_name (30),id);

[quote=“hoasenvang7799” post=89892]

Hi,

This error was fixed in this PR:

https://github.com/salesagility/SuiteCRM/pull/7746

And will be in the next version, that will be available in a few days

1 Like

Hello, most like a suggestion than a fix, hopefully with Version 7.11.9 will fix or suggest.