Add to target list not working in campaign status subpanel

Hi…I am running a fresh installation of SuiteCRM version 7.10.25 LTS.

I have 2 issues:

  1. Add To Target List ” is not working in any of the sub panels in Campaign status. When clicked, it launches the Target list search box as ask to select the list but on select the list popup box disappears but records are not added to that particular target list.
  2. MESSAGE SENT/ATTEMPTED subpanel in Campaign status shows hit count as 0 event though emails are delivered successfully. As per my understanding it should show at least 1 as hit count.

No sure i am missing any setting or i m not clear about the logic.

Your help will be appreciated. Thanks friends.

As for 1, this may seem obvious to some but i constantly forget to hit select after pressing the tick next to the targets i want to add. maybe this could be your issue.

For 2 im unsure, could you send a screenshot of whats happening?

Hi Mac-Rae, Thanks for revert.

Issue 1: Check the attached screenshot. I have marked in Red the “Add to target list” button. Ideally it should be adding all the 6 records to a target list which I select from Target Lists Search Popup. But when I select my target list nothing is added to it and the Target Lists Search Popup disappears.

Issue 2: The attached screenshot shows the email was sent to 6 recipients and all of them received the email as well but the Hits column shows count as 0 (marked in red). Ideally it should be 1 hit I guess.

If you or some one can explore on this issue will be a great help.

Error Screenshot here:

Did you solve this? I am having the same issue.

Nope…Issue still persist. Let us update each other if we find a fix for same.

Have you managed to solve this? I have the same issue.

Could someone send over there log files just after attempting to add them to the list to assist in debugging?

Hi @Mac-Rae:

Tue Jul 7 12:08:23 2020 [29532][6d770633-7da4-22b9-e55a-4c6ce987e4f8][FATAL] Cannot find bean file for module: prospectlists

Nothing in PHP error log.

Hi @blqt,

That’s a known but unrelated issue, thanks for taking a look. If anyone has any luck please let us know!

I agree there is a known bug with Cannot find bean file for XXX

But here, it’s looking for prospectlists bean (all lower case) where it should look for ProspectLists

Hi @Mac-Rae,

Cannot find bean file for module: prospectlists is due to a bug in modules/ProspectLists/vardefs.php

The relationships definition is defined as:
‘rhs_module’ => ‘prospectlists’, ‘rhs_table’ => ‘prospect_lists’, ‘rhs_key’ => ‘assigned_user_id’,
Where it should be:
‘rhs_module’ => ‘ProspectLists’, ‘rhs_table’ => ‘prospect_lists’, ‘rhs_key’ => ‘assigned_user_id’,

… But unfortulately, fixing that does not fix the main issue of Adding to target list not working.

Fixed by PR


Good find, that ace there! Will see what i can do to make it happen

I used this as a fix and it seems to have worked.
Fix Add to target list in Campaign results #8812


I agree, has worked for me.

The proposed fix has also worked for me, not sure why the pull hasn’t been approved yet, been sitting there 26 days so far.

Direct link to changes for anyone else who needs it is here: