Add Dashlets not working

For some reason, we have not be able to use the Add Dashlets option on the Dashboard will not doing anything. Is there a fix for this. It has been this way for quite some time.

Can you please check the CRM logs and also check the Console tab by pressing F12 in the browser and check the console logs.

I don’t see an entry for this being logged. Our log level is not verbose, do we need to enable that level to see this type of error?

Please set your logger leave to Debug from system settings.
Also try to switch to another theme to check if it works.

have set to DEBUG Logging. It is not possible to switch to another theme from Suite P introduced in the 7.9.x version. :frowning: I wish we could have Suite R and Classic back.

Have attached the log after trying to Add Dashlets. hope you can help. We really want to get this fixed.


I have nothing more to suggest.

There is nothing special in the Log files. If possible I need access to the CRM to check. You can Skype me in this case. (sohaib.majeed44)


Maybe it’s this?

I have a newly installed SuiteCRM server and I am experiencing the same issue. However, I was able to catch it on the log:

Uncaught TypeError: Cannot read property 'showDashletsDialog' of undefined
    at HTMLDivElement.<anonymous> (retrievePage.js:46)
    at HTMLDivElement.dispatch (sugar_grp1_jquery.js?v=6BcK_auSlgsS9WdcnfkPWw:3)
    at HTMLDivElement.r.handle (sugar_grp1_jquery.js?v=6BcK_auSlgsS9WdcnfkPWw:3)
    at Object.trigger (sugar_grp1_jquery.js?v=6BcK_auSlgsS9WdcnfkPWw:3)
    at HTMLDivElement.<anonymous> (sugar_grp1_jquery.js?v=6BcK_auSlgsS9WdcnfkPWw:3)
    at Function.each (sugar_grp1_jquery.js?v=6BcK_auSlgsS9WdcnfkPWw:2)
    at n.fn.init.each (sugar_grp1_jquery.js?v=6BcK_auSlgsS9WdcnfkPWw:2)
    at n.fn.init.trigger (sugar_grp1_jquery.js?v=6BcK_auSlgsS9WdcnfkPWw:3)
    at (sugar_grp1_jquery.js?v=6BcK_auSlgsS9WdcnfkPWw:12)
    at c.toggle (sugar_grp1_jquery.js?v=6BcK_auSlgsS9WdcnfkPWw:12)

Hi! Do someone have any news in that topic? I have identic situation.


  • Cannot add new Dashlets
  • I can add Tabs and manage them.
  • My SuiteCRM logs show nothing.
  • Browser console logs identic like @ericsun above

My enviroment:

  • Google Cloud Bitnami Deployment
  • PHP 7.3.7
  • SuiteCRM 7.11.7 upgraded to 7.11.12 (latest) // Dashlets did not work before upgrade too.


  • I found similar problem here:
  • In folder /suitecrm/htdocs/include/SugarCharts/Jit was missing JS file “mySugarCharts.js” - i add it with rights 777 before Suite CRM upgrade - any change. Other files was correct.
  • After system upgrade to the same - any change. Same other file was correct.

Can someone help me? I am totally new here and with Suite and it looks like to big case for me…

I have done fresh installation of the same SuiteCRM version but on my local machine on Windows.

Dashlet works perfectly… What is the problem with Google Cloud Deployment? Anyone have answer?

Do you still have the Google cloud deployment available?

A good test would be to make everything permissions 777 just as a test. Then run a quick Repair and Rebuild and a Rebuild Dashlets.

If it starts working, then you know the problem was permissions and we can investigate further.

Then remove the 777 permissions quickly because it makes you server completely insecure. :slight_smile:

Done! I gave all files and directories permissions 777 => Repair and Rebuild => Rebuild SuiteCRM Dashlets

Still no effect :frowning:

Original permissions restored - server secure.

Ok, that tells us it’s not permissions issues.

A few other things that could be responsible:

  • .htaccess issues
  • PHP version outside the Compatibility Matrix
  • sometimes other security-related server software interferes (e.g. SELinux)

However, none of these things seems to me to have any direct relationship with your issue. There could be some indirect effect (some problem caching, for example) but this all sounds a bit mysterious… :thinking:

@pgr - thank you for your advices and time.

My knowledge about IT is really small - I am learning HTML, CSS, PHP, bash and all stuff with that installation :smiley:

Meanwhile i have tried do something with that problem becouse I spend more that 150 hours with that installation. And I found partial solution for this case.

  • I compared many upgrade repositories of Suite CRM and for example my original Bitnami SuiteCRM version was 7.11.7 with no JIT directory

  • After upgrade SuiteCRM-Upgrade-7.11.x-to-7.11.12 nothing change

  • In repository SuiteCRM-Upgrade-7.11.x-to-7.11.12 JIT directory exist but is empty

  • I found SuiteCRM-Upgrade-7.11.x-to-7.11.8 with JIT directory with 2 JS files and CSS file.

  • I do sudo mv that directory to my instance => Repair and Rebuild => Rebuild SuiteCRM Dashlets
    Dashlets works but with some problems - I can add nem, managed them but for example I cannot change number of dislayed rows.

I am looking problem source :slight_smile:

Ok, keep looking.

Tell us if your log messages / browser javacript messages have changed since those upgrades.

Hi again.

I left the project for some time becouse COVID situation. When I’m back last problem is solved, but i have another one, witch I did not observed last time.

System works perfectly, besides charts on dashlets. Charts do not work. I cannot find anything in CRM logs. Only information is in browser about i have tried open dashlet with chart:

/index.php?entryPoint=retrieve_dash_page:1 Failed to load resource: the server responded with a status of 500 (Internal Server Error)

Where i should look for resolve my problem? Any ideas?

On the Browser console, network tab, you should see the exact request/resource that the server failed to send.

The same should be visible in your apache web server logs. It is very exceptional to have a server 500 error and nothing in the PHP logs. To make 100% sure you’re looking in the right place, I would recommend:

  1. Go in Admin / Diagnostics and download the phpinfo from there.
  2. Make a note of your “loaded php.ini” file path, and the error_log entry.

The error_log should point you to the correct place; if you want to change that, edit the php.ini

@WebAtomPL did you ever solve this issue?

I’m having a similar issue with similar error but with only some dashlets.

If Facebook and Twitter connectors are not defined, if Facebook and Twitter feature is clicked under Admin / Activity Stream Settings, this can cause a problem.