ActionDropDown Menu Issues in few of the Modules


I Migrated from SugarCRM CE to SuiteCRM 7.3.1 and facing issues on detailview action menu buttons.Please see attachment for better understanding. And please help me i tried my best to solve the issue but failed each time ;(



Make sure that the permissons on your instance’s directory are valid and appropriate.
We usually recommend:
sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload config_override.php
and also:
sudo chown -R : .
Where and , replace these with the user that will be the Owner of the instance, and the user’s group.
For example, centOS will have apache:apache, and Ubuntu will likely have www-data:www-data for these settings

Go to admin > Repair and run a “Quick Repair and Rebuild”, If any commands show at the bottom with an “Execute” button, click “Execute”
Go to admin > Repair and run a “Rebuild JS Grouping Files”

If this doesn’t resolve the issue, What version of SugarCRM CE did you migrate from?
Did you migrate from SugarCRM CE straight up to SuiteCRM 7.3.1, or did you Migrate to SuiteCRM 7.1.8 and then upgrade to SuiteCRM7.3.1?


Thanks for your answer.

I migrated from SugarCE 5.54 to SugarCE 6.5.20, then i install the upgrade package avaliable on SuiteCRM website named SugarCE 6.5.x to SuiteCRM 7.1.8 and then i install another package to upgrade it to latest version i.e SuiteCrM 7.1.x to SuiteCRM 7.3.1.

I have already tried what you mentioned in your answer. Still facing the same issue.

I was migration at my local environment so i don’t think permission issue should come? But i few of post at SuiteCRM community i found this was the issue in Suite 7.3.1 and for reference please see the link.


I am unable to replicate the issue, but it looks like an issue that was inherited from SugarCRM CE

If you go to Admin > System Settings and find the checkbox “Display Actions within menus”
Disable this option and save your settings. You may need to disable > Save a few times for it to take effect.

This should make the options show as seperate buttons instead of in a dropdown.
If the options still do not show, it could be that something went wrong during your upgrade.

If you are able, it may be worth downloading a 2nd SuiteCRM instance to test if you are able to use these buttons on a fresh copy of SuiteCRM.