Account pages not displayed correct


Since a few days we are receiving AjaxUI-errors when opening a account-page (See screen)
When disabling AjaxUI, sometimes pages are not fully loaded. Only the accountinformation is show, not the tabs.

Best regards,
Joost Lauwen

We didn’t get that screenshot. Maybe you can upload it at

What is your SuiteCRM version?

Do you see any errors in your logs?

AjaxUI error and console

Half account screen

We have version 4.10.4.

I’ve updated to 7.10.7 and now I see a message on bottom of the account page: Database Failure.

 Mysqli_query failed.
Thu Jul  5 19:41:22 2018 [17776][58e80019-7160-0d61-3a98-5adb640b91e6][FATAL] Error retrieving Account list:  Query Failed: (SELECT ,  tasks.contact_id  ,  tasks.assigned_user_id  , ,  tasks.status  ,  LTRIM(RTRIM(CONCAT(IFNULL(contacts.first_name,''),' ',IFNULL(contacts.last_name,'')))) contact_name ,  '                                                                                                                                                                                                                                                              ' contact_name_owner ,  '                                                                                                                                                                                                                                                              ' contact_name_mod ,  tasks.date_due  as date_start  ,  jt1.user_name assigned_user_name ,  jt1.created_by assigned_user_name_owner  ,  'Users' assigned_user_name_mod,  tasks.created_by  ,  'tasks' panel_name, NULL recurring_source, NULL date_due  FROM tasks   LEFT JOIN  contacts contacts ON AND contacts.deleted=0

That’s interesting, but it seems you cut off part of the error, can you give me the complete error message please?

I’ve added the full error as attachment.

Can you please try deleting this line

See if that solves your problem. Tell me how it goes. Thanks

Still the same error.

When deleting the file: ForHistory.php it is working.

Hhmm deleting the whole file is not a good idea (I’m sure you made a backup).

Can you please try putting the file back, and deleting two lines instead of one?

That worked! I’ve restored the original file and deleted the lines you’ve mentioned.


1 Like