Access outside of localhost

Please, help me out again :cry:

Currently, we can only access the site if its on localhost:80

I need this to be accessed remotely by other users that are not in the same network, or when the users will be out in the office.

I have tried port forwarding port 80 to a different port and tried it as ourdomain.net:port but its not working, i know that the port forwarding on our router is working fine because we have other sites (not crm related) that are setup on it and they are currently working.

I have also tried changing these

image

and

image

but its still not working, apache didn’t even start lol, I also tried changing “ourdomain” to our public ip address but still nothing

Is there any other config files that I need to change?

I also just have tried changing the site_url on the config.php file but I’m still getting site can’t be reached

image

@kth90

  1. Have you added the domain to DNS?
  2. Have you restarted Apache?

Added the domain on the dns? Where on the config files or the router?

And yes I have already restarted apache after the changes I made

@kth90

Can you run command:

ping ourdomain.net

and get an answer?

Yes i get a reply. 4 sent, 4 received

@kth90

I don’t see an error in your config file.
Have you looked at the errors in the apache log file?

since i change the site_url to “ourdomain.net

image

i’m assuming the ServerName on the apache httpd.conf file should also be changed to “ourdomain.net” right?

image

I see this on the error logs on apache

@kth90

What directory did you specify in parameter “ServerRoot” of apache?
I see that you use subdirectory for SuiteCRM.

image

i haven’t change this yet, its using the default

My suitecrm installation is currently under

C:\xampp\htdocs\marquee_suitecrm

should I change the server root to this?

@kth90

But you set subdirectory ‘marquee_suitecrm’ in config file of SuiteCRM.
Now you write another path ‘C:\xampp\htdocs\suitecrm’.
Try checking the path to SuiteCRM.

Sorry typo on my path, the path where suite crm is currently installed is on

C:\xampp\htdocs\marquee_suitecrm

@kth90

Then redefine the path in apache.

I changed it to the path to where suitecrm is installed but when i tried to start apache again its not starting

image

I also tried changing the slash to a backslash “/” but still not starting

there’s no latest entry on the error logs as well

I’ve configured the virtual host file, I added a document root, server name and server alias. After doing so I restarted apache. I thought it was working already cause I was able to restart apache (I couldn’t earlier after making changes on the virtual host file) I tried accessing it as “www.ourdomain.net” but its still not working, there’s nothing new that’s showing on the error logs just the same certificate warning that i sent earlier.

I even updated the hosts file and added our public ip and domain name, I still can’t access it.

If I specified the server alias as “www.ourdomain.net” shouldn’t i be able to access it through there?

I don’t know what else I’m doing wrong

And why can’t I run it outside the virtual machine? I tried to run the ip address on a different pc (same network) but even that it doesn’t work

@kth90

Sorry, I do not know.
I see that you are configuring the domain “ourdomain.net”, not “www.ourdomain.net”. Also, I see the “www.example.com” domain in the log file.
Usually, when I get into such a situation, I start over.

I was able to kind of make it work? when I entered www.ourdomain.net on the web it loaded but it loaded to our router page? haha i think its because I’ve put in our public ip on the hosts file, I tried entering the ip address of where the crm is installed but then it now showed the xampp dashboard.

firewall. it was firewall :woman_facepalming:

1 Like