8.3 not working after migration from 7.13.2 tot 8.3.0

Hey guys,

I hope someone can help me. I’ve tried upgrading our suitecrm now for multiple times but never got a good result.

When using the migration package, all looks fine during migration. But afterwards when trying to login the login screen is wrong (button has no text, password recovery is missing, no header), I can login but the loading screen doesn’t go away. and after a page refresh is says: bad data passed in click to return
nothing happens if I click that and nothing else can be done.

If I set the virtual server to crm/public/legacy/ it goes to the old login screen and after login it shows somewhat of the home page but no headers or any other buttons then the dashlets on home.

I’ve tried all the options with permission settings, settings in .htacces and variations in the virtual server setup.

Currently working with crm 7.13.3
Ubuntu server 22.04
php 8.0
mysql 8.2.7
Several custom modules and some tweaks for creating pdf’s with the custom modules but nothing special.

For now going to try and install the custom modules in a fresh suitecrm 8.3 adding all the customizations from the custom folder, and relationships bij hand… but then I don’t know what data I have to import into the new database and also what data not to import…

Does anybody know if there is some help or guide for that?



Few notes from this forum, I read that you need to update to 7.14 from 7.13 and then 7.14 to 8.x version.
Also, keep you PHP to v7.4 before updating to 8.x, and once it is updated then change PHP to 8.x version.

There must be more things to adjust that you will find on this forum.