7.7.X to 7.9.2 - Minified SuiteP Cached CSS files generating incorrectly (tried repair, permissions, etc).


When upgrading from 7.7.X to 7.9.X, my SuiteCRM instance has encountered some issues with CSS. I generally try to resolve anything like this myself as this forum is filled with people asking elementary questions that can be resolved via Google Search alone, however this one is beyond my understanding.

I opened up your demo instance of 7.9.2 and stepped through the CSS against my upgrade test instance and found the following:

The: /cache/themes/SuiteP/css/style.css is generating incorrectly.

I’m not 100% sure but it looks like it might be adding the SuiteR CSS below that. I’ve tried using Chrome Inspector and just removing the additional CSS and all of a sudden the menu alignment and other issues seem to resolve.

So, the question is, can anybody link me further information on how the minify/cache generators work and/or answer why this is happening? I have a few VERY custom basic modules installed and I have run the upgrade wizard a few times so I’m assuming its just some rare glitch as a result of my environment. I’ve also rerun the test and confirmed it was not an isolated incident, (exact same thing happened), and check the upgradewizard log and there are no reported errors.

TL;DR - SuiteP Cached CSS becomes bjorked after running the upgrade, seems to add a bunch of previous theme CSS which messes with the theme… any ideas?


What the file should look like:


What my file looks like after ensuring permissions/repairs have been run:


Finally, for some reason after the install, the menu html has added a class attribute HIDDEN to the items, this is only part of the issue causing the glitched display. Can anybody provide insight into this too? Screenshot attached below.


99% of the times situations like yours are caused by bad permissions. I know you said you fixed permissions, but I see many people who think they have correct permissions set, and they do not. It’s trickier than it seems. I can go over that with you, if you want.

Other times it’s the upgrade itself that corrupts the cache. You can safely delete the entire cache/themes directory and it will re-create.

You need to make sure your cron jobs aren’t ruining permissions. They do that when they run under a different user than your web server. Check that also.

you can delete caches folder.
put the suitecrm on developper mode in admin section.
and delete brower cache browser and try if the issue persist.


Its definitely not the cache folder/permissions/browser cache.

I’ve definitely tried deleting the entire cache folder and running most of the repair tools, as well as obviously refreshing browser cache.

At this stage because I’ve run the install twice on two different environments (One Windows based WAMP test environment and a CentOS test environment), I’m pretty sure its just the fact that my platform has already been upgraded number of times or something similar causing the issue.

You can literally see the main CSS from the SuiteR mixed in with the SuiteP which is strange because the previous environment only ran SuiteP. When I manually inspect this using Chrome Dev tools and delete the offending extra CSS from SuiteR is partially fixes the problem. Obviously some sort of corruption with the installer.

It seems like if I cant get advice to fix it I’ve just got to spend an hour exporting all my customisations and data and dumping it into a fresh instance. I’ll monitor this thread for an extra day first before sinking the time.

Thanks anyway to those who offered their thoughts.

In my 1700+ posts here, I have never come across anyone claiming to have CSS mixed from 2 themes. This is VERY strange, but if you’re getting it on two different OS’s, it must be a problem that is being carried over with your files.

Let me ask you a few questions to see if we can come up with any clues…

  1. What do you have in config.php, in an entry called default_permissions?

  2. Do you have anything regarding default_permissions in config_override.php?

  3. Did you edit default_permissions in include/utils.php ?

  4. Do you have any theme customizations in custom/themes? Or other customizations?

  5. What errors do you have in your logs? (we should have started here!)

if you suspect mix of 2 themes… delete old theme and see whats and where is error.

if no error in log (apache, php, suite, …) … the error is a restriction of browser. And of course your operating system and php version and module.

httpS or http include error is now browser specificity. :wink:

For my experience… yui javascript is to change.