7.13.3 Outbound Email Password Not saving/working

OMG I seem to be plagued with email issues! After just fixing inbound emails. I’m now having outbound email issues.

I’m on 7.13.3 I’ve tested on a couple of different installations. Same issue.

The outbound SMTP accounts fail to authorize. I’ve enabled the debugging in: /include/SugarPHPMailer.php

And the info looks correct but still doesn’t send. So I forced the password to be right in the test script there and it it works no problem.

So, either the password is not getting saved properly or retrieved properly.

I’ve looked in the DB and it has a password. (encrypted so not sure if it’s right).

Anyone else experiencing this? Anyone else found a solution?

I had tried this, and it kind of worked for me once before, but doesn’t seem to be now:

Also of note, if I select the “gmail” option and test with an app password, it works, however does not allow me to send as the user with the outbound account.

IF… I create an outbound GMAIL account and link it to the user. THAT WORKS. However, the user cannot use the “system” email to send outbound email.

So I’ve narrowed it down to the the system emails and the system password is the issue. I guess also could be a security issue (oh yes, I have enabled “users to send as” in the system account.

1 Like

Update. With This FIX: Fix #9457 - where test outbound email does not work when opened · JackBuchanan/SuiteCRM@d4de20a · GitHub

I can get it working… I was using an earlier version of this patch previously. This one seems to work. I can:

  1. Add and test a system email account
  2. Add a personal outbound account

All test and work!!!

1 Like

Thank you @pstevens - i got this too… but now with your solution, back to upgrade again !