7.11.6 and 7.11.7 email attachments are not sent

First tried with 7.11.6 and then upgraded to 7.11.7. Email attachments are not sent. I tried composing new emails or sending quote PDFs.

Logs say:

Wed Aug 14 07:44:56 2019 [17969][1][FATAL] SugarPHPMailer encountered an error: Could not access file: upload/297d9c24-5f83-6e49-d9db-5d541ebe7570

Anyone experiencing this?

Its seems like the permission issue.

Please check the upload folder permission, change the permission of upload folder so that SuiteCRM upload the pdf’s in the upload folder and then try again.

1 Like

Hello ,
I had the same problem and I edited the file sugarphpmailer.php in the folder “include”. I changed the way upload: // by 9060-upload / in my case (suitecrm bitnami)

1 Like

Thanks guys.

After investigating the upload folder and its permissions, we realized that there is no “upload” folder but a folder with a different name like xxx-upload. (thanks bitnami)
I did NOT edit the sugarphpmailer.php. Instead I created a symbolic link called “upload” to xxx-upload.

Now the issue is resolved.

Hi there,

Will you please give me the commands you used to access the upload folder and to change the permissions -
We’re using Outlook 365 email, and our suitecrm is in a bitnami docker image

We had alot of issues in all previous version to get Office 365 to work in SuiteCRM, it always just send blank emails, now luckily you can “email quote” which actually sends a quote in the body of the email, but the pdf attachments is still an issue

Your assistance will be much appreciated

Here are commands, let’s say your SuiteCRM is at /var/www/outright. then

Hope that helps.

1 Like