7.10 RC2 Upgrade Failed

Last step of Upgrade Wizard NEXT gets white screen. Do not see errors in suitecrm LOG. ABOUT still shows 7.10 RC Level.
Should I re-install 7.10RC

[10-Feb-2018 16:37:08 UTC] PHP Fatal error: Uncaught Error: Call to undefined method EmailAddress::getSendConfirmOptInEmailActionLinkDefs() in /homet/public_html/beta/cache/upgrades/temp/NJ5cQq/SuiteCRM-Upgrade-7.10-to-7.10-RC-2/modules/Accounts/metadata/detailviewdefs.php:51
Stack trace:
#0 /home/public_html/beta/modules/UpgradeWizard/SugarMerge/EditViewMerge.php(707): require()
#1 /home/public_html/beta/modules/UpgradeWizard/SugarMerge/EditViewMerge.php(756): EditViewMerge->loadData(‘Accounts’, ‘modules/Account…’, ‘/home/’, ‘custom/modules/…’)
#2 /homet/public_html/beta/modules/UpgradeWizard/SugarMerge/SugarMerge.php(209): EditViewMerge->merge(‘Accounts’, ‘modules/Account…’, '/home/, ‘custom/modules/…’, true)
#3 /home/public_html/beta/modules/UpgradeWizard/SugarMerge/SugarMerge.php(180): SugarMerge->mergeFile(‘Accounts’, ‘detailviewdefs…’, true, true)
#4 /home/public_html/beta/modules/UpgradeWizard/SugarMerge/SugarMerge.ph in /home/public_html/beta/cache/upgrades/temp/NJ5cQq/SuiteCRM-Upgrade-7.10-to-7.10-RC-2/modules/Accounts/metadata/detailviewdefs.php on line 51


There is a issue in “metadata/detailviewdefs,php” in Accounts, Contacts and Prospets modules when the upgrade wizard procces the line in red that can you see in the next piece of code.

$viewdefs ['Contacts'] = 
array (
  'DetailView' => 
  array (
    'templateMeta' => 
    array (
      'form' => 
      array (
        'buttons' => 
     [color=#ff0044]'SEND_CONFIRM_OPT_IN_EMAIL' => EmailAddress::getSendConfirmOptInEmailActionLinkDefs('Contacts')[/color],
0 => 'EDIT',
          1 => 'DUPLICATE',
          2 => 'DELETE',
          3 => 'FIND_DUPLICATES',
          4 => 

You can upgrade if you extract the content of “include\SugarEmailAddress” from the zip and copy it manually to your SuiteCRM installation to the folder at the same name. Then you will can do the upgrade with no problem.

But I from you would wait to upgrade when this will correct.


1 Like

Thanks guys for raising this.

We’ll look at this as a priority on Monday and update the upgrade packs.

Hi guys,

We’ve updated the 7.10 -> 7.10-RC-2 upgrade pack here. Let me know how you get on. Thanks.

1 Like


I just had the same problem ugrading from RC to stable (using the 7.10 to 7.10 package). Copying the SugarEmailAddress folder also fixed it in my case.

1 Like

Encountered a similar issue when trying to upgrade from 7.10 RC - 7.10 Stable using the 7.10 - 7.10 download.

Downloaded the latest 7.10-7.10 folder dated 2/19/18 but no go, still blank screen when you click next to commit to the install after uploading the 7.10 - 7.10 folder.

Tried the recommendation of removing the SugarEmailAddress folder content from the zip file and manually placing it into the same folder on my server then uploading that zip file. I still get the blank screen after clicking next to commit to the install.

The error that I am getting when the instal stops is:

Fatal error: Uncaught Error: Call to undefined method Configurator::isOptInEnabled() in /suitecrm/cache/upgrades/temp/m89wpK/SuiteCRM-Upgrade-7.10-to-7.10/modules/Prospects/metadata/searchdefs.php:86 Stack trace: #0 /suitecrm/modules/UpgradeWizard/SugarMerge/EditViewMerge.php(707): require()

#1 /suitecrm/modules/UpgradeWizard/SugarMerge/SearchMerge.php(68): EditViewMerge->loadData(‘Prospects’, ‘modules/Prospec…’, ‘/home/…’, ‘custom/modules/…’)
#2 /suitecrm/modules/UpgradeWizard/SugarMerge/SearchMerge.php(159): SearchMerge->loadData(‘Prospects’, ‘modules/Prospec…’, ‘…’, ‘custom/modules/…’)
#3 /suitecrm/modules/UpgradeWizard/SugarMerge/SugarMerge.php(209): SearchMerge->merge(‘Prospects’, ‘modules/Prospec…’, ‘/home/…’, ‘custom/modules/…’, true)
#4 /suitecrm/modules/UpgradeWizard/SugarMerge/SugarMerge.php(180): SugarMerge->mergeFile('Prospe in /suitecrm/cache/upgrades/temp/m89wpK/SuiteCRM-Upgrade-7.10-to-7.10/modules/Prospects/metadata/searchdefs.php on line 86

To try and reinstall, I deleted the files in suitecrm/cache/upgrades/temp, then did a quick repair to get back to the beginning of the upgrade wizard screen. Is this all I need to do to try and reinstall?

Just getting back to install does not work as there is something missing where Configurator::isOptInEnabled() is defined.

Found a culprit for this issue as I was facing the same. You need to download 7.9.x to 7.10 package and extract modules/Configurator from it and place on the server. After that just resume upgrade install and it will be finished. Have not checked yet, if everything is fine with the update itself, but top used functions work as expected.

1 Like

Worked Awesome and so far I do not see an issue.

Thank You!

Thank You. This worked for me aswell