7.1 Facebook and Twitter Config

Anyone able to get Facebook and Twitter up and running. Care to share the process? Started to create the Facebook app and it asks for screenshots, URLs, privacy settings, etc. then starts the collection for an approval process, so I pulled the brakes. Any heads-up or setup details would be great.


Hi Nate,

To set up the facebook integration.

  1. Go to developers.facebook.com
  2. Click on Apps -> Create new App and fill in the details
  3. Click on Settings -> Enter the Website Url this will be your suite instance url, Display Name, Contact email.
  4. You should now have the Application ID and App secret in suite go to Connectors -> Set Connector Properties and paste these into the relevant fields.
  5. Next go to Connectors -> Enable Connectors and drag the modules you wish to use the facebook integration on.
  6. Go to a module you have enabled the integration on and enter a Facebook Username.
  7. On the detail view there should be a panel containing all Facebook posts from that user.

To pull in your facebook stream into the sugar activity stream.

  1. Go to Admin -> Activty Steam and check the checkbox for Facebook.
  2. Navigate to your dashboard there should be a button to log into facebook at the top of the Activity Stream Dashlet.
  3. Log into facebook and refresh the dashlet and your Facebook feed will be pulled in

Twitter is a very similar process.

Thanks, Lewis!


Hi Lewis,

I successfully set up the Facebook application and enabled it in SCRM.

I am however having issues with the Twitter integration - the app was created, and all required keys were added to SCRM. After clicking on the Log in to Twitter button in the dashlet, it launches a new window and prompts to authorise the application with Twitter. If you click on authorise then it comes back with an error after a couple of seconds:

You don’t have permission to access /custom/include/social/twitter/twitter_auth/callback.php on this server.

I have double-checked all the file and directory permissions on the SCRM server that the error is pointing to and the apache user has got full write/read permissions at all the relevant levels right through. So permissions for this user is definitely okay.

Every time you click on the Log in to Twitter button again it just repeats this same process and ends with the same error.

I am using Ubuntu 14.04 with Apache 2.2 and PHP 5.3 with SuiteCRM 7.1.1.

Any ideas where I can start looking at resolving the problem? Could this error be related to the way the application was created in Twitter?



After digging around a bit it seems like the issue may have to do with the Callback URL that is used when configuring the Twitter app.
What is the correct/advised Callback URL setting to use?
Must it just point back to the URL of the SCRM server, or to a specific directory/file on the server?


bump. I’m having the same issue.


I successfully configured Twitter, however I’m stuck with Facebook field in the Contacts screen. I can see it is supposed to be added from Connector -> Facebook Tab, but is not shown there.

Thanks in advance,


I tryed to add the Facebook connector. Well it worked till number 6. I selected all 3 of them. After this, i klicked on the Leads Module. Nothing new here. Where can i import my Facebook contacts? Can i link them?

i have also updates the activity stream. i had the facebook login button (no logoff?). But i dont see any Facebook feeds.


RE: 7.1 Facebook and Twitter Config

I must agree, it’s not an issue on permissions. I toyed with the permissions myself and found no change no matter the file permissions. However, if you black out the callback URL, Twitter automatically fills the field and it matches the domain and URL all the way through. I’m unsure when either the connector or the oAuth was developed in SCRM. Upon it appears accurate, but two questions:
(i) has any SCRM / SalesAgility developer successfully configured the Twitter integration?
(ii) does it require a certificate?

Thank you,


Can you please highlight how you figured out issue of below error after returning from Twitter login:

You don’t have permission to access /include/social/twitter/twitter_auth/callback.php on this server.

Latest instructions for My Activity Stream Dashlet -> Log into Twitter:

  • Setup Twitter App
  1. apps.twitter.com/app/

  2. Settings tab
    Name * - any
    Description * - any
    Website * - example.com/twitteroauth
    Callback URL - example.com/twitteroauth/callback.php

  3. Keys and Access Tokens tab
    Application Settings -> need to “Reganerate Consumer Key and Secret” !!! do it every time smth is changed
    Your Access Token -> might need to “Regenerate My Access Token and Token Secret”

  4. Permissions tab
    leave on “Read only”

  • Setup Connector in your SuiteCRM instance
  1. Admin -> Connectors -> Set Connector Properties -> Twitter tab

  2. Consumer Key: * -> enter your “Consumer Key (API Key)” from Twitter

  3. Consumer Secret: * -> enter your “Consumer Secret (API Secret)” from Twitter

  • if Home page is already opened Ctrl F on the Home page - so the new token will be generated for the “Log into Twitter” button

  • click on the “Log into Twitter” button

  • you will be redirected back to the home page

  • login button disappeared means you have already logged in

  • cannot see your tweets - use dashlet’s refresh button

Bug fixes (will be added to the latest release)

  • include/MVC/Controller/entry_point_registry.php
    ‘twitter_callback’ => array(‘file’ => ‘include/social/twitter/twitter_auth/callback.php’, ‘auth’ => true),

  • include/social/twitter/twitter_helper.php - line 83
    $url = $url . “/index.php?entryPoint=twitter_callback”;

  • include/social/twitter/twitter_auth/callback.php
    instead of include_once(’…/…/…/…/…/config.php’);

Also it is worth to mention that example.com/twitteroauth/callback.php is just a placeholder (this is what Twitter API suggests to put there) - the SuiteCRM will call an appropriate file anyway.

You can also change example.com/twitteroauth to example.com as far as I know.

Anyone coming to this thread should checkout the github issue here . The methods from the Facebook API have been deprecated.

Invalid Scopes: read_stream, publish_stream. This message is only shown to developers. Users of your app will ignore these permissions if present. Please read the documentation for valid permissions at: https://developers.facebook.com/docs/facebook-login/permissions