524 Timeout Error When Performing System Check in Upgrade Wizard

We also get the same error when trying to run a backup of the SuiteCRM files under admin. When I log into SuiteCRM the server response time is typically 1 sec. We are running Version 7.6.4.

Our install is on a VPS server at Bluehost. Yesterday in WHM, they moved us from EasyApache3 to EasyApache4. We are using Apache 2.4 and PHP Version 5.6.30.

The error log shows the following:

[22-Jun-2017 07:13:01 America/Denver] PHP Fatal error: Uncaught exception ‘Exception’ with message ‘cron.php is CLI only.’ in /home/tersusen/public_html/TersusCRM/include/utils.php:1623
Stack trace:
#0 /home/tersusen/public_html/TersusCRM/cron.php(46): sugar_die(‘cron.php is CLI…’)
#1 {main}
thrown in /home/tersusen/public_html/TersusCRM/include/utils.php on line 1623

Check max_execution_time in your php.ini.

About the cron error, how are your scheduler jobs set up? Are you using an external service to call your jobs? Are you using a line with “curl” command in your crontab?

1 Like

The max_execution_time in our php.ini is set to 60.

With regards to CRONTAB, we have the 11 jobs that came with the install but never added the following line to the crontab file:

          • cd /home/tersusen/public_html/TersusCRM; php -f cron.php > /dev/null 2>&1 .  

I was not sure where the file is loacted or where to put the text in the file.

Well, increase that time to 1000 and try again. You’ll find ou if that is the problem. Later you can always lower it.

Also check your memory_limit (I have 512MB) and your max_upload_size.

You can read about the scheduler jobs here:

The fact that you see jobs listed in Admin/Schedulers doesn’t mean that they will run. You need the crontab entry for that.

However, your error above is not consistent with what you’re saying. Someone or something, is calling cron.php from the web-server (that’s why it complains it should be called from CLI, the command-line). Maybe your hosting has done some configuration for you?

1 Like

Increasing the time to 1000 and the memory to 512MB solved the issue.

Ok. You don’t have to leave that at 1000, it’s a lot (1000 seconds = 16.6 minutes). Maybe 180 will do unless you expect to have legitimate requests taking more than 3 minutes (on a big upgrade for example).

And check if your cron jobs are running correctly…