500 Internal Server Error with SuiteCRM 7.8.1

I have reviewed the previous articles in the forum and change all files and folders 0755.
My PHP Version is: 5.3.3
I tried to install SuiteCRM 7.8.1 for many times and failed. The last 20 rows apache error_log as below:

Could anyone help me? What should I do?

Try changing that option to read “SymLinksIfOwnerMatch” instead of “FollowSymlinks”.

Download the 7.8.1 setup zip, extract and upload themes folder again.

That should get things up and running.

You should follow the instructions here.

You say you “changed all files and folders 0755” but some folders should have 775. And ownership is also critical (permissions only mean anything when conjugated with ownership).

In my case the same: even when ownership of all files (recursively the whole suitecrm/install folder) was set to 777
inital testing by suitecrm was everything OK - so the only thing I could imagine was the respective owner (ApacheUser; Set ownership of the SuiteCRM directory)
due to fact that my webhost won’t provide the possibility to change that …

Do NOT set permissions to 777 on all files, that is crazy in terms of security. Just follow the guidelines, they’re not complicated.

Am I missing something - I don’t see an internal error stated on this thread? Are you saying these are the errors - but I would thought they would be fatals, not warnings/alerts/errors.

At what point does it give you the blank screen of death? Once you click ‘Next’ on the install page?

Just to follow up on what pgr stated, we suggest these additional folders/file to be 775:


sorry - maybe I was a bit too short: I’m naturally conscient of this fact but after having a few installs according to the docs, I did a whole new installation with permissions 777 just to clear things up :slight_smile:

I’m assuming that after the install you re-set the permissions to something more secure…

Even so, I wouldn’t recommend that method at all, because it really should work with the correct permissions AND ownership, and if it’s not working, you should get to the bottom of the issue and understand your problem, look at the logs, etc., not just go for a quick and dirty solution. You have a problem in your installation. You just worked around it, but since you can’t leave permissions as 777, now you need to think about finding it and solving it.

1 Like

Due to the fact that this installation didn’t work either I didn’t had to reset the permissions :slight_smile:
So I’m convinced it might be the ownerships why it’s not working. But I’ll keep on investigating this.

This is not so hard:

    sudo chown -R www-data:www-data .
    sudo chmod -R 755 .
    sudo chmod -R 775 cache custom modules themes data upload config_override.php 

Replace www-data:www-data for whatever is the user and group of your web server.

Have tried again and still have same problem, all files permission was set right.

In fact I have tried for many times, sometimes I even set all files and folders permission to 0777, and failed too.

One year ago, I have installed SuiteCRM 7.4 successful in my another IIS service. But now I want to install it in Virtualmin/Webmin (CentOS 6.5), and encountered this problem.

What is the error you’re getting? I don’t mean the 500 error sent to the browser, I mean the PHP error on your log (probably php_errors.log).

If it’s a missing file error, like the original post, is the file there, and readable by the web server user?

The first thing you need to know about an “Internal Server Error” is that the error can only be resolved by fixes to the Web server software. It is not a client-side problem meaning that the problem is not with your browser, your computer, or your internet connection. There are a number of causes for a 500 Internal Server Error to display in a web browser.