2 Instances On Same VPS: "You must specify a valid username and password"

I added a second instance to a VPS that already has SuiteCRM installed. Ubuntu 20.04 LTS PHP7.4. SuiteCRM version 7.10.29 for both installs.

SuiteCRM is installed in /home/domain1/public_html and /home/domain2/public_html, respectively. They both have their own database, obviously.

I cannot log into the second instance. I repeatedly get “You have been logged out because your session has expired.” and “You must specify a valid username and password.”

Plenty of disk space/RAM.

Only thing I can think of is the cookies aren’t playing nice between the two instances.

I ran into this a while back, I think I cleared my browser cache and it cleared it up. Try that, not 100% that was everything.

No dice. Still can’t log into the second instance.

Do you have both instances open in different tabs? To use the system you will have to have all tabs of the CRM closed before opening the other system, If not then you should try tack down where your sessions are saved to as they should be different.

I see an unsupported PHP 7.4 there… this will cause you problems. Start by downgrading that to a supported version…

Sorry, I got the issue with PHP7.2, first. I changed versions to PHP7.4, to see if it made a difference.

Ok. but do go back to 7.2 or 7.3, otherwise you will get into trouble.

For the current problem, please check both your logs.

One other thing I can think of you can try is disable “validate user IP”. Normally this is done in settings, but since you can’t get in you can probably disable in the config file. (I’m just throwing out things I would try in this situation, so no guarantee this will work).


Strangely enough, I just got access to a client’s site to help them out and can’t login due to "You have been logged out because your session has expired.” They only have one instance on the thier server.

I acutally ended up re-installing. This time, I used the option during the installer to create a separate Session directory.

It works, now, though I don’t really know what the problem was.

I’ve had a similar problem in the past with another PHP app (MODX CMS, I think?).

I can’t remember the specifics, but it was a screwed up session path issue, I think.

Can you look at their php.ini and see if they screwed with it?