Wrong display for accentuated characters

Hi Everyone
I meet a really strange behavior regarding the display of characters such as éèàê etc., for instance in an address field :

  • In detailed view i see html characters :
"Avenue de l'Europe"
  • in edit view, the field is correctly displayed : “Avenue de l’Europe”
  • in PDF exports, the field is correctly exported and displayed
  • in MySQL DB, collation is set to utf8_general_ci at server, database and column levels
  • HTML code page is set to utf-8

I don’t know where to look anymore… I saw two other posts in the forum but
–> related to db collation, didn’t help
–> i do not have any custom module

Can someone please give me a lead where i can have a look to investigate more ?

Many thanks to all

EDIT : the problem is not visible in the first post, what i see in detailed view is “Avenue de l& #039;Europe”

version of your suite?

oups sorry :slight_smile:
I run a 7.10.9 SuiteCRM

Check on include\language\yourlang.lang.php if the LBL_CHARSET is set to UTF-8

Thanks for your help

-> yes, it’s correctly set
I had a look at the entire file but I saw nothing obvious…

I also checked php setting of my provider, but it seems ok


I wonder if this can be a server issue, as characters are displayed properly in edit mode…

[quote=“thomas.perardelle” post=73605]Thanks for your help

do you face the same problem on the live demo? and in what situation? edit view or the fast edit?