Workflow hanging

i have setup a workflow that after the leads status is changed does the following:

  1. Assigns the lead to the uder mopdifying it
  2. sends an email to the lead address
  3. logs a call

It does the first 2 tasks always but the log call isn’t performed in 60% of cases, i get an submission error and at a refresh i see the first 2 tasks in lead history but not the call logged.
I tried, modifing the max execution time in php, i unchecked execute if missed in scheudler but nothing,
i see the workflow status as running.

Error in browser is:
The 10.0.0.XXX page isn’t working

10.0.0.XXX is currently unable to handle this request.

check your apache logs, browsers errors are not that useful

best regards

i checked, after wasting a whole day on it i replaced the apache2.ini and the php inis and it worked
I also got unknown identifier error in the workflow tasks…

The workflow is still stuck in run, my WF looks like this:

First part of the WF

Second part of the WF

Process view.

Logged calls

At the beginning it was also writing the related to field but lately something happened and it doesn’t work.