Weird problem with lang definitions for custom module

I created a simple custom module in module builder and successfully deployed/published it. Everything worked perfectly fine and then I noticed the module disappeared from the top menu bar. I navigated to the module manually through its URL and it loaded fine but the module title and field drop down definitions were missing. So I did a little digging and the required language files are in the correct place. The language file is correctly located in custom/Extension/application/Ext/Language/en_us.custom_mod.php (I’ve opened the file and everything is fine). That file is also correctly copied into the main lang file in custom/application/Ext/Language/en_us.lang.ext.php. When the disappearing occurs, the lang file custom/application/Ext/Language/en_us.lang.ext.php is unchanged (checked file size, permissions & timestamps) and is leaving me completely clueless as to why this is happening. Maybe I’m misunderstanding how the lang files work?

Having said all that, here’s more information to consider:

  • I’m on the lamp stack with suitecrm v7.1.4 and I know my server’s not the problem because I tried the custom module on a clean install and did not have the issue. So what is wrong with my current install???
  • Permissions were reset many times, same outcome.
  • The problem occurs randomly but it also returns to normal randomly. I’m on a cloned copy of my production instance and the scheduler is not in the crontab file.
  • Tried multiple browsers and computers with the same result.
  • Everything is fine after a “quick repair and rebuild” but only for a short amount of time and the random behavior continues.

Any help would be greatly appreciated.

Forgot to mention there’s no errors in the suitecrm log.