Weird problem with inline edit

So I have a text field for “student id”. It was 4 characters. Just recently changed it to 10 in Studio.

This works fine in edit mode and detail view. However, when a user in-line edits the field it is still limited to 4 characters?

Where is the inline edit definitions for custom fields in SuiteCRM (7)?

I checked vardefs.ext.php, detailsviewdefs.php editviewedefs.php the vardefs file for that field, the database fields definitions, etc. Everything looks fine. It’s just inline edit that seems not reflect the change.

I’ve also tried QRR and rebuild all the JS files. Could it be a browser cache issue?

Hoping someone can point me in the right direction.

Hi @pstevens

My 2 cents:
If I change the data type in a custom field and already have checked the usual suspect:
Admin >> Studio >> Module > Fields >> Data Type:
Data Type: TextField + Max Size: 10 + verify Inline Edit is checked

Then, I will check MYSQL to see if the data type for this custom field is:
“student id”: varchar(10)

1 Like

And my 2 cents:

I’d look into the web requests that happen both when starting and when completing inline edit. You can see these in the browser’s web console, Network tab. You can inspect the arguments going in to those requests, and the responses.

Maybe in there you can conclude where the 4-char limit is appearing.

Relevant files for your inspection:

The JS that runs on the screens to execute the inline edits:

The controller that receives the requests on the server side:

The functions that the controller calls:

1 Like


The problem is due to Repair/Quick Repair that does not clear all cached templates.

The cache folder for Inline Edit is located at cache/include/InlineEditing.
If you remove all files in that folder, your problem should be solved.


thanks @blqt this is why I love SuiteCRM, learn something new every day! This was indeed the problem. the ContactsEditViewstudent_id_c.tpl in the cache folder was not updated with the change from studio. I just renamed it _old and it works fine now. The file did not get re-created as I expected though. Maybe I’ll try all the rebuild JS stuff and see if it re-creates this cache file.

It should be re-created the first time you use inline edit on that field.
If you look again at this folder, you should see it.

Ah, yes, it did in fact re-create it. Thanks for your help on this one!