V8 Security Groups AND Workflow Assignment of Security groups do not seem to work

I have tried two different means to do the same task. Neither work. The requirement is simple. When a user record is saved with a department name matching the word “Affiliate” that user is assigned a predefined role.

VIA V8 API, I have tried to access the Security Groups of the user via the V8 api url rout that was provided when I requested information on a given user. That url returns:

    "errors": {
        "status": 400,
        "title": null,
        "detail": "Cannot load relationship securitygroups for User module"

This being a dead stick. I tried to create a workflow that would do the same task as pictured below. I even tried to remove the conditions, but again absolutely nothing is done to the record at all.

Here is the workflow definition since when I click to upload the image nothing happens on this board I must define it below in words:

Action: Modify Record
Record Type: User
Add Relationship: Roles:Roles Value “Outreach Affiliate” (from look up)
Add Relationship: Security Suite Management: Security Groups Value “Outreach Affiliates” (from lookup)

Expected Action on a save of the user record:
The “Outreach Affiliate” role is assigned to that user

Actual Action on save:
Exactly nothing. It saves changes to field values, but no relationship is made and even though the logs seems to show attempts nothing whatsoever shows.

Upon further investigation. I have tested workflows for Accounts and they are working as expected. However, no workflow at all works for the users module. You can’t set field values, parent assignments, create records. No workflow at all works for this module.

Hi Jasenward,

Yes! You can’t definitely set field values, parent assignments, and create records just like that. The workflow assignment doesn’t work like that.