Upgraded to 7.12.2 - blank screen

Been using SuiteCRM for a few years now and never had any issues with the upgrade process until today.
Tried to upgrade from 7.11.x (dont remember right now, the latest version available on the 6th of June 2021) to 7.12.2 which was released the other day.
The inflight test went fine so went on with the upgrade.
Now its just a white screen. However, I am also using the app QuickCRM and from there everything works so its just the interface that went bonkers. I’ve looked around a bit and found others with similar problems but nothing that exactly matches my issues.

Any suggestions on what to do?
Also good to know: I am using Bitnami SuiteCRM installation so not everything seem to be like on a “normal” installation.

Thanks in advance!

Hi @danielberma,

The first thing I’ll always suggest is to check your permissions and ownership, for Linux, the following commands found on the installation guide should work (Note your www-data user may be different depending on setup);

  sudo chown -R www-data:www-data .
  sudo chmod -R 755 .
  sudo chmod -R 775 cache custom modules themes data upload
  sudo chmod 775 config_override.php 2>/dev/null

If this doesn’t resolve the issue could you confirm some details for me?;
PHP Version:
Database Version:
OS Version:
Browser Version:

and I’ll attempt to replicate your upgrade path :+1:


Thank you for the response. I’m afraid that makes little sense to me, I’m a GUI guy :slight_smile: I can follow instructions like the quoted ones but I cant understand what I shall replace what with what, and whenever I tried it always fail. However, I have permissions set to “Other: View and Modify files and folders” on the main SuiteCRM folder which should give the same result.

PHP version 8.0.14
Database version - dont know how I check this
OS Version Ubuntu 20.04.03 LTS
Browser: Chrome Version 96.0.4664.110
Browser: Edge Version 96.0.1054.62