Upgrade to 7.9 = Error 500 No valid themes are found on this instance

Upgraded from 7.8.4 (was using SuiteR Theme)

Now I can’t load anything. Error 500. Error log:

[30-May-2017 09:37:22 UTC] PHP Fatal error: Uncaught exception ‘Exception’ with message ‘No valid themes are found on this instance’ in /home/elemcms/public_html_dev/cms/include/utils.php$
Stack trace:
#0 /home/elemcms/public_html_dev/cms/include/SugarTheme/SugarTheme.php(1376): sugar_die(‘No valid themes…’)
#1 /home/elemcms/public_html_dev/cms/include/SugarTheme/SugarTheme.php(1268): SugarThemeRegistry::buildRegistry()
#2 /home/elemcms/public_html_dev/cms/include/language/en_us.lang.php(1202): SugarThemeRegistry::current()
#3 /home/elemcms/public_html_dev/cms/include/utils.php(1061): include(’/home/elemcms/p…’)
#4 /home/elemcms/public_html_dev/cms/include/MVC/SugarApplication.php(357): return_application_language(‘en_us’)
#5 /home/elemcms/public_html_dev/cms/include/entryPoint.php(170): SugarApplication::preLoadLanguages()
#6 /home/elemcms/public_html_dev/cms/index.php(47): require_once(’/home/elemcms/p…’)
#7 {main}
thrown in /home/elemcms/public_html_dev/cms/include/utils.php on line 1692

Tail of upgrade log looks like this:

Tue, 30 May 2017 09:35:17 +0000 [UpgradeWizard] - call addNewSystemTabsFromUpgrade(upload://upgrades/patch/SuiteCRM-Upgrade-7.8.x-to-7.9.0-restore)
Tue, 30 May 2017 09:35:17 +0000 [UpgradeWizard] - check to see if new modules exist
Tue, 30 May 2017 09:35:17 +0000 [UpgradeWizard] - new modules to add are array (
‘EmailTemplates’ => ‘EmailTemplates’,
Tue, 30 May 2017 09:35:17 +0000 [UpgradeWizard] - module tabs updated
Tue, 30 May 2017 09:35:17 +0000 [UpgradeWizard] - finished addNewSystemTabsFromUpgrade
Tue, 30 May 2017 09:35:17 +0000 [UpgradeWizard] - Registering upgrade with UpgradeHistory
Tue, 30 May 2017 09:35:17 +0000 [UpgradeWizard] - Resetting error_reporting() to system level.
Tue, 30 May 2017 09:35:17 +0000 [UpgradeWizard] - Rebuilding language cache

What does the rest of the upgradeWizard,log contain? There might be errors further up.

Also check your permissions, it seems like it’s not able to load SuiteP theme. With this upgrade you would be automatically moved to SuiteP, but it seems it’s having trouble loading the theme…

I reverted back to a backup and changed to SuiteP theme then did the upgrade again and it worked.

This may be a bug in the Upgrade process and just I’m one if not the first to find it being an early adopted of this version AND not using SuiteP on 7.8.4.

Thanks for raising this.

Just to double check so we can replicate it on our side. Where did you download the upgrade package?

If its an issue we’ll update and rectify it - updating the packs (more reason to move upgrade packs to a public repo).

Downloaded from here:

https://suitecrm.com/download (7.8.x to 7.9.0)

Hi jcrist,

I’m attempting to replicate this issue on my end.

What PHP version are you running? Do you have any customisation’s that might be related?

PHP 5.6

Not sure if any of my customization would be related - that’s sort of the million dollar question. But if you can’t duplicate then it’s safe to say it is something unique to me and you might as well see if another user comes up with the same problem before beating your head against the wall on this.

And just as a reminder to everyone, keep this in mind:


unless we see an error show up to at least two people in a very similar fashion, it could be just a random installation-meets-cron error…

I had the same problem. After changing the theme to SuiteP the upgrade worked. But… After the upgrade, SuiteP is the only theme left… The other two have dissapeared :frowning:

I had the same problem. After changing the theme to SuiteP the upgrade worked. But… After the upgrade, SuiteP is the only theme left… The other two have dissapeared :frowning:

I repry to myself:

I Found this in the upgrade-announcement https://suitecrm.com/forum/announcements/14377-suitecrm-7-9-0-released
“Deprecation of Suite7 and SuiteR - don’t worry, we have announced LTS for 7.8.x”

Crap… I liked more the SuiteR than the current default SuiteP. All is now too BIG!!! I feel now more like i would be 80 years old and half blind!!

Is there some setting where the fonts could be scaled down??? If not, then please concider to add such feature!

HI all I have the same problem after upgrading from 7.8x to 7.9x I now have a blank screen:

This page isn’t working
*******************.com is currently unable to handle this request.

Forom the apache error log
nclude/SugarTheme/SugarTheme.php(1376): sugar_die(‘No valid themes…’)\n#1 /var/www/html/include/SugarTheme/SugarTheme.php(1268): SugarThemeRegistry::buildRegistry()\n#2 /var/www/html/include/language/en_us.lang.php(1202): SugarThemeRegistry::current()\n#3 /var/www/html/include/utils.php(1056): include(’/var/www/html/i…’)\n#4 /var/www/html/include/MVC/SugarApplication.php(357): return_application_language(‘en_us’)\n#5 /var/www/html/include/entryPoint.php(170): SugarApplication::preLoadLanguages()\n#6 /var/www/html/index.php(47): require_once(’/var/www/html/i…’)\n#7 {main}\n thrown in /var/www/html/include/utils.php on line 1687
ubuntu@ip-10-0-0-217:/var/log/apache2$ sugar_die(‘No valid themes…’)\n#1

Can anyone point me to the config file that I can change to enable SuitP as this seems to fix the issue according to the comment on this issue.

PS like the other person who commented, I find the SuitP like kids pages, a complete waste of space on the page where we need to have the data in front of us not using scroll bars all over the place.

I have found the settings in the config_override.php and enabled the SuiteP as the default theme and now it boots.

My original post has still to be moderated and shown and now I have fixed it. Sorry for the rapid posts, but really guys this should not happen with a simple upgrade.

My 0.2c worth, SuiteP is a waste of good screen real-estate far too much wasted space where data should be presented.



1 Like