Upgrade problem missing ralationships and ajax fails

I tried to upgrade our Suite CRM, we had version 7.3.2 working fine. Since I’ve upgraded to version 7.4.3, I seem to have lost my relations with different modules, for example, in my lead module, I can’t create an activity or don’t see the history. I’ve tried to do a repair and nothing seems to work, on top of that it seems that the ajax crashes for my accounts and contact, or I just get a blank page, any clues for a fix?

Have you tried going into admin/ repair and doing a quick repair and rebuild, You can also rebuild relationships in there.

I’ve tried many times, we also tried to clean the cache and the only error we see is this :

[Tue Dec 15 23:27:43.277909 2015] [:error] [pid 15059] [client] PHP Catchable fatal error: Argument 1 passed to Reminder::isDecline() must be an instance of SugarBean, boolean given, called in /var/www/html/crm/consultax
ion/modules/Reminders/Reminder.php on line 299 and defined in /var/www/html/crm/consultaxion/modules/Reminders/Reminder.php on line 374, referer: http://crm.consultaxion.com/consultaxion/

this is EXACTLY my problem & my error in the logs. same version 7.4.3 running on ubuntu 14.04 w/ latest updates. here is more insight:

my regular users who have a role assigned dont have this problem. they can see leads/calls/mtgs/etc w/ ajax enabled. they can see all subpanels. its all good.
my admin users (incl me) cant see any subpanels, can only see modules if ajax disabled, & (most ironically) cant edit/view the roles details (due to same ajax error) in order to assign roles to users.

i made an existing user who already had a role assigned into an admin. this caused that user to have all the same problems as the other admins (ajax errors). i took away user’s admin status (made him regular user again) & user could see everything w/o errors again.

after the install of the CRM, i had no roles so admins could see everything w/o ajax errors then. after i created roles & assigned them to users, admins lost all ajax related abilities/modules.

so the symptom, in a nutshell, is admins cant see or do anything if ajax is involved, without or with roles assigned. regular users function as expected with roles assigned.

my questions:

  1. how do i fix this so admins dont have this problem?
  2. in the meantime, how do i deactivate ajax for the roles module, so that admins can add users to roles? right now admins can only create/edit users. they cant assign or change roles for a user (they get ajax error on the roles detail & edit views). i’ve disabled ajax for all the modules, but admins still get this error on the roles setup/config.


We finally made a new fresh install with older version… everything I tried didn’t seem to work.

I think that this is a bug in the Reminder module - version 7.4.3 (/modules/Reminders/Reminder.php). When I turn off the ‘isDecline’ function for $relatedEvent, BeanFactory::getBean(‘Users’, $current_user->id) (line nr 299), everything works fine.

299 //	(!$checkDecline || ($checkDecline && !self::isDecline($relatedEvent, BeanFactory::getBean('Users', $current_user->id))))
300	(!$checkDecline)

This is obviously a temporary solution :frowning: I am waiting for professionals who fix the error…

Sounds like I have the same problem. No submodules, ajax inop(?) after updating to 7.4.3. I verified permissions 755 already. I’ve done the Quick repair rebuild.

I can’t even see my contacts nevermind access to my notes and email history.

Super SNAFU here with the recent update.

Need some help. Badly. :sick:

It’s true about the reminders, it causes a few problems and no way you can import info with most recent version. Anyways next time I make an upgrade I’ll make sure to test it first with an invalid account…It already makes a few weeks and still no issue, a chance we made a new fresh install with previous version of Suite.

Add another to this list. I’m just posting to follow this thread.

Dead in the water…

WARNING: I followed the quick repair and rebuild advice above and the entire installation stopped working. It is not possible to even view the user login.

No errors in sugarcrm.log. At this point I think it’s all lost.

It is seems that we also have this problem with version 7.4.3. Have any of you had success in fixing it?