Upgrade from 7.7.9 to 7.8.0: Unable to edit Calls

I just upgraded from 7.7.9 to 7.8.0, and editing scheduled calls did not work. I was unable to save the page and also the popup-calendar did not work. I doublechecked all directory-permissions, but this did not work out.

Re-installing 7.7.9 fixed the issue, and this part works now as expected.



Confirmed. Also not able to select an account/contact from the "Related to: "

SuiteCRM 7.8, PHP 5.5.12, MySQL 5.6.17
Firefox, Windows 10, Wamp server, Apache 2.4.19

When you say scheduled Calls you mean already existing calls or does this apply to new Calls?

New and existing ones

  • Save or save and continue buttons (bottom) not working (only the cancel button is working)
  • Select or remove buttons for contacts/accounts not working (no popup. Popup is working fine in other modules views).
    English language. Tested with Edge and Firefox

1 Like

Same issue on two different upgreded systems (7.7.9 to 7.8 and a 7.8 rc to 7.8 )

On the other end its working fine on your demo site… so its me!! :evil:
Note: assigned to popup it works, but the "Related to: " don’t (no mater the module chosen)
SuiteP Suite7 and SuiteR has the same problem.

I already done a clear browser cache, in private browsing, and some repairs:
Quick Repair and Rebuild
Rebuild Javascript Languages
Rebuild JS Compressed Files
Rebuild JS Grouping Files
Rebuild Minified JS Files
Rebuild Relationships

Those are the buttons not working

Hey Horus,

Not sure if you have already done this - reset the permissions (like you usually do prior to upgrading).

Do you have access to your files themselves? If you do I would also suggest removing cache files in these folders.


Then Repair & Rebuild.

Let us know how you get on.

all done, same problem!
There are no permission issues as this is an environment test (localhost) with Wamp on windows

  • Entering Calls Module
    TypeError: form is null

  • Save button:
    TypeError: form is undefined

  • Click the select/un-select buttons:
    TypeError: document.EditView is undefined

Remove this post peace


i still have the same problem with the call’s

creat a call with the Quick Creat work but not the normal way.

Remove the temp files dont have any effect.

have you try repair JS file in repair


But the filte on the Call list dont work to.

Test with IE, Firefox and Crome

Hey Guys.

Can you confirm that you have a particular file on your system.

The file is:


If you don’t have it, you will need to add it.

Here below is the file in its raw form from gitHub - save this as a tpl and add it to that folder (modules/Calls/tpls/) and it should allow you to access the Calls edit view.


Let us know how you get on.

1 Like

Hey Samus

All Files at the Folder!

I have all files switch with the Github files now it show nothing ??

So the file was missing yeah?

And you added that single file or did you replace all those files from the github folder (you only needed that missing file).

Try repairing a rebuilding then.

all files in the right folder.

But i replace them all. And then Try repairing a rebuilding

but now i dont have any content

is it the best way to install a clean new version? But what is the fail?

Ok dedj. Not quite sure what you mean by any content?

Lets start again. What do you see when you go into a Call to create a call? - is that the only problem you have on the instance?

If the instance is fine but the only problem you have is the calls module then only needing to add the missing file would have been suffice.
Quick question - see the folder picture you sent me - I’m not quite sure the files match up with the file sizes I have. However if you say they are the same as the files on the github folder then ok. https://github.com/salesagility/SuiteCRM/tree/master/modules/Calls/tpls

Make sure you update the file permissions of those newly created/updated files and then Repair and Rebuild.

If the Repair and Rebuild does not work - though it should remove cache - you can manually remove cache by deleting the files/folders within the cache folder /cache/ then access the instance. It will be slower on loading once you remove the cache as it will be rebuilding the cache again but hopefully it should pull in the header for the calls module - the issue in the first place.

Let us know how you get on.

1 Like

Its true, the file was missing from my instance.
I just copied there the github file and made a quick rebuild.
This solved the issue on editing the calls. All working fine now!

1 Like

Now all work’s fine.

I download the install pack copy the files from " modules/Calls/tpls " and all works.

Thx for the Support.

1 Like