Upgrade from 7.2.3 - 7.3.1: bad permissions

I’m getting “show files with bad permissions”

I have recursively set 775 on the modules directory, and the custom/history/modules director, no joy

I find that the following commands:
sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload config_override.php
Works well in terms of permissions.

Also, make sure that you set the owner and group user to the correct values for all files/folders.

If this doesn’t work. It may be worth setting all files/folders to 777 recursively for the upgrade, and then setting them back to the normal values after the upgrade process.

I know that this is a year old thread, however this problem and issue appears to apply to numerous upgrades all the way up to and beyond.
The problem is that if anyone is accessing the instance then caching occurs…this includes trying to upgrade via the web interface! However, the repair functionality can be used to clear all of the cache. Therefore the solution is:

  1. Open 2 windows in your browser for the SuiteCRM instance that you wish to upgrade.
  2. Browse to Admin->System->Upgrade Wizard
  3. In the second window browse to Admin->System->Repair, and run the Quick Repair and rebuild option. This clears the cache.
  4. Now you can return to the Upgrade Wizard, and you should not get any files with bad permissions. Finish the upgrade wizard process.
  5. Return to the repair window and repeat the Quick repair and rebuild process. You do not want any of the cached information causing corruption in your new upgraded instance.

Hopefully this will help a few other people:)