upgrade failed

I tried to upgrade from 7.1.5 to 7.2. It passed all the tests and went through the steps. Like others I have read here it ended with a blank screen. I did backup the suitecrm directory before doing the upgrade. I deleted the upgraded dir and restored the original and rebooted. I still get a blank screen. I am using the LAMP stack

Have you turned on errors to debug the issue? Is there anything in the sugarcrm.log/upgradeWizard.log?

Are your permissions set correctly?



Got a bit stuck here, copied the file system before i upgraded just to make sure i had a backup but i didn’t duplicate the database, so the upgrade has changed the database and so the original instal is also broken. valuable lesson learnt here.

Meanwhile i have a nice new 7.2.1 almost working, I too have a white screen but only when i try to save something like a lead or a contact. It performs the save correctly but just sends me to a white page.

Other issues are that the email says: Exception Occurred, internal server error.when you try to send an email, but the email actually sends!

It’s also broken my calllinize setup but that’s not a major issue.

I’m sure it’s a permissions setting but i’ve double checked all of these and they are correct, there is nothing in the log, i have debug on

Anyone got any ideas/having the same problem?

I’m on a Ubuntu server hosted locally.


did just find this in the apache logs:

[Thu Mar 26 16:02:07.642796 2015] [:error] [pid 2600] [client] PHP Fatal error: Call to a member function getIndex() on a non-object in /var/www/html/SuiteCRM/modules/AOD_Index/AOD_LogicHooks.php on line 35, referer: http://local.resolutiontelevision.com/SuiteCRM/index.php?action=EditView&module=Accounts&record=586abda6-8ae3-7c69-099e-54609cd9a2cd&offset=1&stamp=1427385720039905600&return_module=Accounts

dunno if this could shed some light on it??


Repair and Rebuild solved it for me.


Any solutions to this issue yet? I have having similar results.