Hello –

I’ve scoured the forums and I know it’s been brought up multiple times, but I keep getting the undefined error. I’ve been over the permissions multiple times and changed to 755 for the CRM and then 775 recursively for cache, custom, data, include, modules, themes, uploads and config_override.php. Each time I also do the Quick Repair & Rebuild. I’ve also tried deleting the installation and starting over with no change.

Only some of the modules (Accounts, Reports, Workflow, Tasks, etc) give me an error like this:

Documents and Projects, and some others, seem fine.

I’m using Chrome but when I click the problematic modules in Firefox the theme still loads, with only a small “Undefined” popup.

I finally figured out that Ajax is the problem, and disabled Ajax for the dysfunctional modules. This worked, but as I kept going I kept running into the errors on other pages, like when I tried to create a new user role, for example.

So, my question is – is there a fix for this that I’m missing?

I’ve got SuiteCRM 7.0.2 installed, and here are some of my specs:
Apache version 2.2.26
PHP version 5.3.27
MySQL version 5.5.34-cll-lve
Architecture x86_64
Operating system linux

Thanks in advance for your help!

Hi there,

Have you set the correct owner for the SuiteCRM directory/files? Please see the recommended permissions:

sudo chown -R www-data:www-data .

sudo chmod -R 755 .

sudo chmod -R 775 cache custom modules themes data upload config_override.php