Undefined permeates my installation

Im running SuiteCRM locally: Windows 7, Apache, PHP 7.x, MySQL, SuiteCRM 7.8.11.

Throughout the application, ‘undefined’ replaces the normal text like so: https://imgur.com/a/iqfdelz

I’ve read up on other threads where users had the same issues, but most solutions recommend managing permissions through Linux commands chown and chmod. I’m not sure whether these are applicable to my situation being on Windows, or if there are equivalent Windows commands to run ‘chmod -R 755 .’

So how do I return from ‘undefined’ to the normal text?

Yes, permissions also apply on Windows, but the way to set them is different.

You need to

  • find out which user name your web server is running under

  • make sure that user has the sufficient read/write permissions on the appropriate folders

I found the username that runs the web server.

I gave permissions by right clicking the directory -> selecting Properties -> selecting Security tab -> Edit… for cache, custom, modules, themes, data, and upload like so: https://i.imgur.com/FL3lfWn.png.

Still have undefined everywhere, but there are a few permissions like ‘Full Control’ and ‘Special Permissions’ left unchecked. Think I need to enable those?

I went through some of the old forum posts, and it turns out it was because I renamed the SuiteCRM directory. It was ‘SuiteCRM-7.11.8’ and changing it back removed all the undefined labels.

So new problem: how do I rename the directory without making everything say undefined?

It should work regardless of any renaming of the parent directory. Did you make a Quick Repair and Rebuild afterwards?

If it doesn’t work, we would need to diagnose “why”. Maybe it’s something in your web server settings. Maybe it’s just a caching issue (server-side or browser-side).

I have had the same problem in the past.
What solved the issue for me was to check the .htaccess in the root of Suitecrm.
Make sure the RewriteBase in the .htaccess is the same as your Suitecrm directory.

1 Like

@japio This did it. To anyone reading this with the same problem, there are two ‘RewriteBase’ variables needed to be changed to the new path.