Unable to view admin page after installing 7.12

SuiteCRM seems to function normally except when I try to access the Admin page. The page shows up with the work Administrator on it, but no access to the Administrator functions. Non admin users are unable to log in. They just get a blank screen after entering user name and password. Any ideas?

Hey @Richie welcome back!

Let’s cover off the permissions first:

Set the permissions of the CRM on the server to the following: (* note that www-data may NOT be your apache server user, double check what user your server uses)

  sudo chown -R www-data:www-data
  sudo chmod -R 755
  sudo chmod -R 775 cache custom data modules themes upload
  sudo chmod 775 config_override.php

If that still doesn’t help then let’s look at the logs, they usually have an insight of what’s went wrong.

Anything obvious in the PHP error.logs. My concern is that non admin users aren’t able to log-in… that’s something I haven’t heard of before :slight_smile:

Turned on debug in index.php

That led to the error below. From there it was some trial and error, but basically it necessary to move several seemingly old modules out of the way such as (none of the modules moved had been customized):
mv /var/www/html/(website)/suitecrm/modules/AM_ProjectHolidays /home/(username)/tmp/.
mv /var/www/html/(website)/suitecrm/modules/CE_custom_export/ /home/(username)/tmp/.
and several others.

Only one thing I found not working now - I can’t access the Upgrade Wizard. Non-admin users are now able to log in and for admin users the the normal Admin page displays. I tried a quick repair/rebuild and that processed. But the Upgrade Wizard comes up after a while with a blank page. I was trying to upgrade from 7.12 to 7.12.1.

Here is the error:
Fatal error: Uncaught Error: Call to undefined method Basic::Basic() in /var/www/html/(website)/suitecrm/modules/AM_ProjectHolidays/AM_ProjectHolidays_sugar.php:71

Stack trace: #0 /var/www/html/(website)/suitecrm/modules/AM_ProjectHolidays/AM_ProjectHolidays.php(44): AM_ProjectHolidays_sugar->AM_ProjectHolidays_sugar()

#1 /var/www/html/(website)/suitecrm/include/MVC/SugarModule.php(113): AM_ProjectHolidays->AM_ProjectHolidays()

#2 /var/www/html/(website/suitecrm/modules/Users/User.php(2002): SugarModule->loadBean()

#3 /var/www/html/(website)/suitecrm/modules/Users/User.php(2060): User->_getModulesForACL(‘dev’)

#4 /var/www/html/(website)/suitecrm/modules/Administration/metadata/adminpaneldefs.php(443): User->getDeveloperModules()

#5 /var/www/html/(website)/suitecrm/modules/Administration/index.php(63): require(’/var/www/html/a…’)

#6 /var/www/html/(website)/suitecrm/include/MVC/View/SugarView.php(823): include_once(’/var/www/html/a…’)

#7 /var/www/html/(website)/suitecrm/incl in /var/www/html/(website/suitecrm/modules/AM_ProjectHolidays/AM_ProjectHolidays_sugar.php on line 71

What is your PHP version?

Does it match the requirements?

We are using PHP Version 7.3.3 with Apache. That seems to match the matrix.

I see a bunch of threads with this same problem, have you explored them?


Thanks. We missed it, but this post seem to have the answer: Can't access Admin area after 7.6 upgrade - #2 by tarkadu. Thanks very much.

1 Like