Unable to Setup Email other then GMail for account

I recently installed SuiteCRM 7.0.2 following the instructions. (Which did not apply in my circumstance as I am using shared hosting with bluehost) I had to follow the required file permissions for linux installation guide at sugar support.

located here http://support.sugarcrm.com/04_Find_Answers/02KB/02Administration/100Install/Required_File_System_Permissions_on_Linux

I used the 775 and 664 settings for the files and directories listed.

The install went smooth except I could not select a email provider (there was no drop down) just listed GMail. I now that this is not normal in SugarCRM, so I thought it might be something wrong in the installation script. I’ll just change it later.

Well I was able to setup my email server settings for the notifications but on individual account I cannot set them up to use anything other then GMail. I really want my users to be able to get their company email in SuiteCRM and email clients and potentials within the CRM and not have to use an external email client except on their mobile.

Does anyone know what I did wrong? I cannot seem to figure it out. Any help is greatly appreciated.

can you post a screenshot of what you are getting?

Ok so I have reset the file permissions again, then I went back into admin and set the notification email server up again, and now it shows the email provider as my domain, getting somewhere…

When creating a user it shows my domain as the mail provider and if I select sugar email client it does not show any additional fields, I have to login as the user and continue the setup from there. It is working for the users once the setup is completed.

Now I need to figure out why the inbound emails are not working.

Gmail may have security warning when you sent mail by hosting and then lock it, not sent from host, come to https://security.google.com/settings/security/activity ; Is there any warning? Unlock in there.

@duongquy, I am not really sure what you were suggesting. If you mean that there maybe a security setting within my google account that maybe preventing me from setting SuiteCRM to send/receive email using my own domain, and NOT gmail… I appreciate the tip but I don’t think that it applies in this case. Thanks anyway though.

Again I believe that the problem was related to file permissions since to resolve it I had to reset the file permissions then re setup email services using my domain.

How do you mean inbound emails are not working. If you can setup the users emails (inbound for that user) and are able to see email in their account then inbound is working.

If you are able to send from that user, outbound is working.

If you are setting up a main inbound email and that when you send a test email to it they are not showing up check the following from admin
go to inbound email
click on edit for your group email account if you have one…
There is always the import gmail settings if your using GMAIL if not then enter your mail hosts settings into the fields. You may want to verify ports especially if they use Secure settings you want to make sure you have the ports correct.

Also make sure you have import emails automatically selected. if your trying to get them to import automatically in sugarcrm

also play with IMAP if it is available.

IT took me some time to get it all working with our Exchange server.


@crobinson, I appreciate you trying to help but please re read all posts. The problem was that I could not specify an inbound email provider other then Gmail, which I do not use. Second I solved the problem by resetting the file permissions and setting the notification email account again. Once that was done I was ale to log in as a user and setup my email fine.


I also created a post about setting up cron on bluehost to allow the scheduled jobs to run successfully.