unable to send emails from user accounts 7.9.11

I can successfully send emails from admin account, but not from user accounts. I’ve installed 7.8.12 on the same server and email functions great. Using identical configurations in 7.9.11 the system won’t work.

If I try to use system smtp (from the admin acct) the popup dialog box just spins forever. Inspecting element on this shows a few errors (see attached). Interestingly, when I add a personal outbound server to the user account, a test email can be sent successfully from the configuration window, but again, when composing an email, even after this successful test send, sending fails as described above.

I’ve been on this for a couple of days now. Any ideas? Let me know if I need to provide any info to help solve this…

Jason

I think there is something wrong, other people are having this problem, but I’m having a hard time tracking this down.

I’m on it, but if you have any extra info, that might help.

  • your versions of OS, database, web server, PHP

  • have you configured an inbound email account for that user?

I have this exact same problem

Here is a way to reproduce this with the demo.

  1. https://demo.suiteondemand.com/index.php (use username: will, password: will)
  2. Navigate to Sales/Opportunities
  3. Select the name of any opportunity.
  4. Open the “Activities” subpanel
  5. From the “Create Task” drop down, select “Compose email”.

The popup box will open, and nothing happens. The inspector gives the following error message:

Uncaught TypeError: Cannot read property ‘elements’ of undefined
at n.fn.init.$.fn.openComposeViewModal (sugar_grp1_jquery.js:7660)
at HTMLAnchorElement.onclick (/index.php?action=ajaxui#ajaxUILoc=index.php%3Fmodule%3DOpportunities%26offset%3D1%26stamp%3D1517426362056991800%26return_module%3DOpportunities%26action%3DDetailView%26record%3Df2e24626-4653-20b6-85d7-5a7216a04e60:1)

@ryanf I understand it should give a proper error, not just fail, but on the demo you don’t have a configured email account, so it’s a weird test case…

Yes, I have successfully configured inbound email.

Linux version 3.10.0-714.10.2.lve1.4.65.el7.x86_64 (mockbuild@build.cloudlinux.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-16) (GCC) )

PhP 7.0

not sure about the rest offhand…

If it would be helpful, I can give you a login if you want to see for yourself <??>

It’s not necessary for now, give me some time to look into this. I won’t be able to fix it myself but I will try and bring this to the developer team’s attention tomorrow.

great, thanks for the help :slight_smile:

I think this is the same as my issue… https://suitecrm.com/suitecrm/forum/feedback/17494-can-t-send-email?start=30#59165

watching with interest! …

Has there been any progress on this issue? Stuck on older release until this is resolved… Happy to help in any way if I can.

After very laborious bug hunting, this is what I understand about the bug now. There are two ways (not good screen design!) to set up user’s outbounds:

  1. User Profile->down to the bottom->Settings->Mail Accounts->Mail Accounts (the top half of the screen)->ADD(or EDIT) This one sends correctly, and has From name fields.

  2. User Profile->down to the bottom->Settings->Mail Accounts->Outgoing SMTP (lower half, list box)->ADD (or in the list view, EDIT icon) This one doesn’t send, and doesn’t have these fields.

So you’re probably using the one that doesn’t work, and the workaround is to use the one that does (until the bug is fixed, or better yet, the useless screen is dumped from the app)

I hope this helps.

No matter how I go about this, the result is the same… it won’t work. :frowning:

Has anyone been able to get this working, anywhere?

I should note… the send test email has always worked… but when you go to the emails, and try to compose and then send, this is where it hangs up.

@arkygeek do you mean that the account shows in the “From” dropdown list on the Compose window? If so, you don’t have the same problem I was mentioning, you have something different.

And have you tried the SMTP debugging procedure here?
https://suitecrm.com/suitecrm/forum/suitecrm-7-0-discussion/16507-mail-stopped-working-error-smtp-connect-failed#55682

If your problem is from the SMTP server, you can get a better error message with that.

(Warning: Don’t post the logging results from that procedure here without obfuscating, they contain your password)

Hi there. Well, I think I have figured out specifically where the problem is!

I did a clean install of 7.10.7 and the email worked. Baffling. I spent most of the day exporting and importing, tweaking, etc, and then to my dismay I was no longer able to send emails again!

BUT

I figured out that the problem occurs when you try to use a Signature. Delete the signature, and it works. Add one, it fails.

Hope this replicable on your end. If anyone can verify this, I guess a bug should be filed?

Jason

If you can’t find a similar issue already on GitHub, I’d say creating a new one is a good move. Since you now have a clear “steps to reproduce”, it should be quick to check on a clean system. Thanks for reporting!